Package Details: qmmp-plugin-pack 1.3.1-1

Git Clone URL: https://aur.archlinux.org/qmmp-plugin-pack.git (read-only)
Package Base: qmmp-plugin-pack
Description: Qmmp Plugin Pack
Upstream URL: http://qmmp.ylsoftware.com
Licenses: GPL
Submitter: PerfectGentleman
Maintainer: ava1ar
Last Packager: ava1ar
Votes: 23
Popularity: 0.149804
First Submitted: 2013-08-12 11:36
Last Updated: 2019-07-14 03:05

Dependencies (7)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

ava1ar commented on 2019-02-22 14:06

gdamjan, thanks - updated.

gdamjan commented on 2019-02-22 07:03

the PKGBUILD needs some fixups - there's no LIB_DIR - compiling in the source directory is not recommended in cmake

diff --git a/PKGBUILD b/PKGBUILD
index 80bf725..d7b3ff6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,12 +14,13 @@ source=(http://qmmp.ylsoftware.com/files/plugins/${pkgname}-${pkgver}.tar.bz2)
 sha1sums=('e844fe7cdc041728244c0a207159291b1f4c0a16')

 build() {
-       cd "${srcdir}/${pkgname}-${pkgver}"
-       cmake -DCMAKE_INSTALL_PREFIX=/usr -DLIB_DIR=/usr/lib -DCMAKE_BUILD_TYPE=RELEASE -DUSE_FFAP:BOOL=TRUE
+       mkdir _build
+       cd _build
+       cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_BUILD_TYPE=RELEASE -DUSE_FFAP:BOOL=TRUE "${srcdir}/${pkgname}-${pkgver}"
        make
 }

 package() {
-       cd "${srcdir}/${pkgname}-${pkgver}"
+       cd _build
        make DESTDIR="${pkgdir}" install
 }

arcanis commented on 2015-10-03 21:44

it requires qt5-tools as makedep (qt-linguist)

ozky commented on 2015-09-24 09:20

I get it builded by first manually builded libxmp as i didn't have qmmp-plugin-pack installed.

ozky commented on 2015-09-24 09:07

Error libxmp 4.2.0 not found.

ava1ar commented on 2015-09-23 02:32

ozky,

builds fine for me. What error are you getting?

ozky commented on 2015-09-22 07:06

It fails to build it cause of libxmp so that's why i asked.

ava1ar commented on 2015-09-21 14:07

Hi, ozky

Major version of libxmp was not changed, pluigin's libxmp.so library dependencies looks good. I do not see anything to update.

If you want, you can just rebuild the package after upgrading libxmp dependency.

ozky commented on 2015-09-20 16:12

Please update to new libxmp 4.3.9.

Garik commented on 2015-09-09 12:20

Thanks, all seems working now.