Package Details: qgnomeplatform 0.7.0-2

Git Clone URL: https://aur.archlinux.org/qgnomeplatform.git (read-only, click to copy)
Package Base: qgnomeplatform
Description: Qt Platform Theme aimed to accomodate as much of GNOME settings as possible
Upstream URL: https://github.com/FedoraQt/QGnomePlatform
Keywords: GNOME Qt
Licenses: LGPL2.1
Submitter: aimileus
Maintainer: j.r
Last Packager: j.r
Votes: 32
Popularity: 2.40
First Submitted: 2018-02-04 11:04
Last Updated: 2021-01-04 12:12

Pinned Comments

j.r commented on 2020-11-23 14:15

From now on I'm going to use https://sr.ht/~j-r/aur-packages-jr/ as monorepo for all my AUR packages. If you want to submit patches for this package feel free to submit them there.

Latest Comments

1 2 3 4 Next › Last »

j.r commented on 2021-01-06 16:20

No problem, I'm glad that @Gilrain found the problem

maxpayne3 commented on 2021-01-06 16:15

Yes, I was missing bison and pkgconf. Maybe deleted months ago during a cleanup. Sorry if I disturbed you. Thanks for your help.

Gilrain commented on 2021-01-06 16:00

I would guess that you didn't install base-devel as recommended by the wiki when using AUR.

maxpayne3 commented on 2021-01-06 15:47

It's not yay, I tried to download the package from github and reproduce the same commands in the PKGBUILD. qmake-qt5 works, but make fails.

cd common/ && ( test -e Makefile || /usr/bin/qmake-qt5 -o Makefile /tmp/QGnomePlatform-0.7.0/common/common.pro ) && make -f Makefile
Project ERROR: adwaita-qt development package not found
make: *** [Makefile:49: sub-common-make_first] Errore 3

I never built this package, used to install the binary from Chaotic repository, but due to issues on their servers, it's not provided anymore and I switched to AUR. Anyway, since make is failing on its own, it's not a yay or makepkg.conf issue, but more likely a missing makedepend.

Sometime I compile pulseeffects-git and it's working, it's weird this package does not have a single makedepend and no one is stated on github project. Do you have an idea of which package I could be missing?

j.r commented on 2021-01-06 12:10

Strange your adwaita-qt package looks right and I can't reproduce your error.... maybe something is wrong with your build setup in general? Maybe you modified makepkg.conf or the search paths for libs or so.... the problem is that qgnomeplatform couldn't find the adwaita-qt lib, although it's there....

maxpayne3 commented on 2021-01-06 10:31

Tried also with the snapshot and makepkg, same result.

yay -Ql adwaita-qt

j.r commented on 2021-01-06 10:25

@maxpayne3 what does yay -Ql adwaita-qt show you?

maxpayne3 commented on 2021-01-06 10:23

It's not asking me anything, I don't need to do a clean build, yay cache is saved on the /tmp, on every reboot it's always a clean build. I also tried to reinstall adwaita-qt rebuilding the package, but it's the same result.

j.r commented on 2021-01-06 09:57

@maxpayne3 I use yay myself and can't reproduce this error. And yes the error happens because the build system of qgnomeplatform (qmake / make) could not detect that adwaita-qt is installed... as I said maybe a clean build of qgnomeplatform or adwaita-qt could help to fix it (it's faily simple to do a clean build with yay, it even asks you if you want to do a clean build)

maxpayne3 commented on 2021-01-06 09:24

The relevant information are in English.

Info: creating stash file /tmp/yaycache/pkgbuild/qgnomeplatform/src/QGnomePlatform-0.7.0/.qmake.stash
cd common/ && ( test -e Makefile || /usr/bin/qmake-qt5 -o Makefile /tmp/yaycache/pkgbuild/qgnomeplatform/src/QGnomePlatform-0.7.0/common/common.pro ) && make -f Makefile 
Project ERROR: adwaita-qt development package not found
make: *** [Makefile:49: sub-common-make_first] Errore 3

The error is in build function.

Later I will try to download the snapshot and make a build with makepkg, maybe it's a yay issue.