Package Details: qgis-ltr 3.16.6-2

Git Clone URL: https://aur.archlinux.org/qgis-ltr.git (read-only, click to copy)
Package Base: qgis-ltr
Description: Geographic Information System (GIS); Long Term Release
Upstream URL: https://qgis.org/
Keywords: GIS
Licenses: GPL
Conflicts: qgis
Provides: qgis=3.16.6
Submitter: saultdon
Maintainer: buzo
Last Packager: buzo
Votes: 14
Popularity: 0.000077
First Submitted: 2015-07-08 16:37
Last Updated: 2021-05-10 18:37

Required by (4)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Tharbad commented on 2018-10-16 18:41

Had plugins errors (missing python libraries. Used https://htmlpreview.github.io/?https://raw.github.com/qgis/QGIS/master/doc/INSTALL.html#toc6 to compile the following list:

python2-dateutil python2-future gdal python2-gdal python2-httplib2 python2-jinja python2-markupsafe python2-mock python2-nose2 python2-owslib python2-psycopg2 python2-pygments python2-pyproj python2-pyqt4 python2-requests python2-sip python2-six python2-termcolor python2-tzlocal python2-yaml python2-plotly

buzo commented on 2018-09-23 18:38

I have added the missing dependencies to AUR, so this package builds again.

Tharbad commented on 2018-09-23 04:32

While attempting to build with qt5, one of the cmake scripts failed (qca). I have this qca installed: https://www.archlinux.org/packages/extra/x86_64/qca/

Ideas will be most welcome.

Tharbad commented on 2018-09-22 19:43

@Scimmia: I see. I'll try anyway as I need the ltr and I prefer not to use a vm.

Scimmia commented on 2018-09-22 18:34

You can try, but it won't work well if at all. There's a reason QGIS3 was a major release.

Tharbad commented on 2018-09-22 18:02

@Scimmia: See 3.9 at https://github.com/qgis/QGIS/blob/release-2_18/INSTALL

I can attempt this build myself and update the pkgbuild if it works but I'm a qgis beginner so I'll need some explanation on how to check if it worked (except for launching qgis).

Scimmia commented on 2018-09-22 05:31

qt5 packages will do no good with this.

Tharbad commented on 2018-09-22 05:20

@guiba: You can try: https://www.archlinux.org/packages/extra/x86_64/qscintilla-qt5/ and https://www.archlinux.org/packages/extra/x86_64/python2-qscintilla-qt5/

guiba commented on 2018-09-21 06:18

anyone knows how to build qgis-ltr even without python2-qscintilla-qt4 and qscintilla from AUR? I have install it with pacman, but does not works. I really needs this version.

rancidfrog commented on 2018-06-10 15:13

Thanks a bunch. I added for sid files the GeoExpressCLUtils-9.5.0.4326-linux64/bin to ld.so.config.d which was conflicting with geos libraries. Removed the conf file and now it launches fine. And qgis-ltr builds fine. Thank you once again, Would not have realized that the other package also used geos.