Package Details: qemu-user-static-bin 5.2-7

Git Clone URL: https://aur.archlinux.org/qemu-user-static-bin.git (read-only, click to copy)
Package Base: qemu-user-static-bin
Description: A generic and open source machine emulator, statically linked
Upstream URL: http://wiki.qemu.org
Keywords: emulation qemu
Licenses: GPL2, LGPL2.1
Conflicts: qemu-user, qemu-user-static
Provides: qemu-user, qemu-user-static
Submitter: dvdhrm
Maintainer: JerryXiao (jpegxguy)
Last Packager: jpegxguy
Votes: 82
Popularity: 0.89
First Submitted: 2017-10-05 07:33
Last Updated: 2021-04-17 12:33

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 Next › Last »

TioDuke commented on 2015-10-24 09:49

Package has been updated to latest debian

I really appreciate when you comment or flag the package out-of-date, so that I can update it properly. What I won't tolerate, is people complaining that the package is bad maintained: if you need to build it in a hurry and you can't wait for me to update, then modify it yourself before doing a makepkg (and if you are using an aur helper, bad luck; you need to undertand that makepkg is the supported Arch way).

michix5d commented on 2015-10-17 15:49

Flagged out of date. Needs new wget URL:
http://ftp.debian.org/debian/pool/main/q/qemu/qemu-user-static_2.4+dfsg-4_amd64.deb

mdl commented on 2015-09-22 05:46

This package currently can't be built because the file on the Debian mirror specified in the PKGBUILD is no longer present; it needs to be changed to "qemu-user-static_2.4+dfsg-3_amd64.deb".

mdl commented on 2015-09-19 07:33

PKGBUILD needs updating again, as qemu-user-static_2.4+dfsg-1a_amd64.deb is no longer on the Debian mirror. The latest package is now qemu-user-static_2.4+dfsg-3_amd64.deb.

jjanzic commented on 2015-09-08 20:20

There's 2.4 out: http://pastebin.com/5DAhLC61

kalsan commented on 2015-07-26 14:24

I'm getting a 404 when installing this. The PKGBUILD from http://pastebin.com/d9swBvqr appears to be working.

vinadoros commented on 2015-07-01 11:09

Hmm, I actually was getting this same error about the "package" line not being found right up until yesterday. I updated the binfmts-support package (there was no version change for it, but my AUR helper seemed to think it wanted an upgrade). After that, it started working with the modified change in this qemu-user-static PKGBUILD. Perhaps that needs an update or something. I don't know why it started working either (I didn't change the qemu-user-static package in any way, and I am using the new format).

DiegoAscanio commented on 2015-06-30 23:17

Sorry, I'm trying to compile yaourt, with makepkg and i'm not reaching it

DiegoAscanio commented on 2015-06-30 23:14

vinadoros, what you proposed does not works with update-binfmt, at least at the most recent version of qemu-user-static package, on debian repo.

when I tried to:
#update-binfmt --importdir /var/lib/binfmts --import

a warning came up saying that the required 'package' line was not found and update-binfmt exited dues to previous errors

I got it working with the old lines in PKGBUILD and using version 6a from debian repository.

Now I'm trying to cross compile makepkg, but it keeps stalling and seg faulting.

Sorry for the poor english.

vinadoros commented on 2015-06-27 17:46

Actually the link to qemu-user-static_2.3+dfsg-5 is also out of date (is now 6a). These lines should work in place of the existing lines:

_debsrc=${pkgname}_${pkgver}+dfsg-6a_${_arch}.deb
source=(http://ftp.debian.org/debian/pool/main/q/qemu/${_debsrc})
sha1sums=('aab940002044c9543a8aaf4502622b03fd06e153')
[ "$CARCH" = 'i686' ] && sha1sums=('51eaaca22d6ccf969623453190cffa62c79de480')