Package Details: qarma-git 44-3

Git Clone URL: https://aur.archlinux.org/qarma-git.git (read-only, click to copy)
Package Base: qarma-git
Description: A drop-in replacement clone for zenity, written in Qt4/5, Qt5 build
Upstream URL: https://github.com/luebking/qarma
Licenses: GPL
Conflicts: qarma, zenity
Provides: qarma, zenity
Submitter: Nierro
Maintainer: prash
Last Packager: prash
Votes: 14
Popularity: 0.000000
First Submitted: 2014-12-14 16:33
Last Updated: 2021-05-14 04:00

Required by (205)

Sources (1)

Latest Comments

1 2 Next › Last »

prash commented on 2021-05-09 12:58

@dreieck I use qarma not because I write my own tools with it, but because there are programs that need zenity, and I want to avoid zenity's GTK dependencies. If qarma does not work for you, by all means, use zenity directly. But this package exists so that those of us who don't want GTK dependencies will have something that works most of the time.

Your suggestion of removing zenity in the provides array would be counterproductive to my purpose.

That aside, thanks for letting me know there are cases where qarma doesn't work. If I come across such cases in my own usage of qarma, I will stop using it.

dreieck commented on 2021-04-27 20:31

This actually is not a drop-in replacement for zenity.

For example, the command

zenity --list --mid-search --window-icon question --title "Automirror" --text="Please select the primary output. All other outputs will be scaled to match." --column Output --column "Width [mm]" --column "Height [mm]" --column "Width [px]" --column "Height [px]"

(Taken from → this script)

displays correctly in zenity, while with qarma it produces a spurious --mid-search in the output (qarma seems not to handle this correctly). → Here is a screenshot of what happens with qarma.

So, I suggest that you remove zenity in the provides array.

Btw., rarr; here I filed an upstream bug report, but I don't expect it to be fixed.

Thanks for maintaining!

micwoj92 commented on 2021-03-21 20:55

Hello, could you update download to git+https?

Nierro commented on 2019-08-30 17:38

Disowning package as i am not willing to maintain it anymore.

WorMzy commented on 2016-04-17 23:14

Where has this versioned tarball come from? Upstream doesn't have any tags..

Nierro commented on 2015-04-12 10:52

@notuxius, sorry for the delay. I did not receive any notification...
Btw it should be fixed now.

notuxius commented on 2015-03-16 10:39

PKGBUILD: line 26: qmake: command not found

Nierro commented on 2014-12-14 18:03

Thank you very much!

KenjiTakahashi commented on 2014-12-14 17:02

It requires qt5-x11extras.

Nierro commented on 2014-12-14 16:35

@bersil: i created qarma-git aur package. Have a look ;)
https://aur.archlinux.org/packages/qarma-git/