Package Details: q4wine-git v1.3.6.11.ge511d2b-1

Git Clone URL: https://aur.archlinux.org/q4wine-git.git (read-only, click to copy)
Package Base: q4wine-git
Description: A Qt GUI for Wine. (GIT Version)
Upstream URL: http://sourceforge.net/projects/q4wine
Licenses: GPL3
Conflicts: q4wine
Provides: q4wine
Submitter: Atterratio
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 17
Popularity: 0.000000
First Submitted: 2011-12-11 04:23
Last Updated: 2018-02-11 00:53

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

vorot93 commented on 2015-03-22 20:53

You could make a common pkgbase for q4wine-qt4-git and q4wine-qt5-git.

Also please enable WITH_SYSTEM_SINGLEAPP for Qt 5 build and add qt-solutions as a dependency.

xuiqzy commented on 2015-03-09 16:09

I just mean it wouldn't cause any problems at the moment because all provide the q4wine pakckage

sl1pkn07 commented on 2015-03-09 16:04

it is not necessary omit them

xuiqzy commented on 2015-03-09 15:52

ok, but in this case it could theoretically be ommited and there would be no problems until there were no qt4 packages that both provide and which would trigger the conflict.

sl1pkn07 commented on 2015-03-09 15:49

q4wine-qt5 is need in conflicts/provides in this package, because all git packages need add the non-git counterpart package (may not exist, yet)

xuiqzy commented on 2015-03-09 15:35

So 2 installed packages are not allowed to provide the same package. But then the qt5-git package doesn't even need q4wine-qt5 in the conflicts, because it already conflicts because both packages would provide q4wine? And there also isn't a qt5 stable package yet.

xuiqzy commented on 2015-03-09 15:32

So 2 packages cannot provide the same package. But then the qt5-git package doesn't even need q4wine-qt5 in the conflicts, because it already conflicts because both packages would provide q4wine? And there also isn't a qt5 stable package yet.

sl1pkn07 commented on 2015-03-09 15:23

no. because q4wine-git and git-q4wine-QT5 packages must point to non-git package (in this case q4wine of [multilib]). as they both have added to conflicts()/provides(). then when you try to install one of them, uninstall the other

greetings

xuiqzy commented on 2015-03-09 15:11

I see it in the other package, that you adopted just now I guess ;D
But doesn't this package here (q4wine-qt5-git) also conflict with q4wine-git?

xuiqzy commented on 2015-03-09 15:03

I see it in the other package, that you adopted just now I guess ;D
But doesn't this package also conflicts with q4wine-git?