Package Details: pytrainer 2.0.0-1

Git Clone URL: https://aur.archlinux.org/pytrainer.git (read-only)
Package Base: pytrainer
Description: A tool to log your sport activities.
Upstream URL: https://github.com/pytrainer/pytrainer/wiki
Licenses: GPL
Submitter: None
Maintainer: None
Last Packager: zoe
Votes: 22
Popularity: 0.000011
First Submitted: 2006-10-18 16:58
Last Updated: 2019-09-21 20:03

Dependencies (11)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

xduugu commented on 2013-04-14 12:00

The issue is that python2-migrate is not compatible with the version of python2-sqlalchemy. You can fix it by adjusting a line in /usr/lib/python2.7/site-packages/migrate/versioning/schema.py.

I've filled a bug report against python2-migrate which includes a patch.
https://bugs.archlinux.org/task/34776

Anonymous comment on 2013-04-14 06:45

When executed via console, I got the following error:

running pytrainer from egg installation
data_path: /usr/share/pytrainer/
gettext_path: /usr/share/locale
site_path: /usr/share/lib/python2.7/site-packages
Traceback (most recent call last):
File "pytrainer", line 96, in <module>
from pytrainer.main import pyTrainer
File "/usr/lib/python2.7/site-packages/pytrainer/main.py", line 36, in <module>
from upgrade.data import initialize_data
File "/usr/lib/python2.7/site-packages/pytrainer/upgrade/data.py", line 23, in <module>
from pytrainer.upgrade.migratedb import MigratableDb
File "/usr/lib/python2.7/site-packages/pytrainer/upgrade/migratedb.py", line 19, in <module>
from migrate.versioning.api import db_version, upgrade, version, version_control
File "/usr/lib/python2.7/site-packages/migrate/versioning/api.py", line 33, in <module>
from migrate.versioning import (repository, schema, version,
File "/usr/lib/python2.7/site-packages/migrate/versioning/schema.py", line 10, in <module>
from sqlalchemy import exceptions as sa_exceptions

xduugu commented on 2012-03-24 12:23

Thanks a lot. It seems the dependencies were reorganized somehow. The python-lxml package was also changed to python3 and a new python2-lxml package was introduced which is the correct dependency for this package.

Anonymous comment on 2012-03-24 09:38

This package should depend on python2-decorator. At least I get an error without it.

zoe commented on 2011-12-16 23:42

When executed, I got an error :

[chris@myhost ~]$ pytrainer
running pytrainer from egg installation
data_path: /usr/share/pytrainer/
gettext_path: /usr/share/locale
site_path: /usr/share/lib/python2.7/site-packages
Traceback (most recent call last):
File "pytrainer", line 96, in <module>
from pytrainer.main import pyTrainer
File "/usr/lib/python2.7/site-packages/pytrainer/main.py", line 36, in <module>
from upgrade.data import initialize_data
File "/usr/lib/python2.7/site-packages/pytrainer/upgrade/data.py", line 23, in <module>
from pytrainer.upgrade.migratedb import MigratableDb
File "/usr/lib/python2.7/site-packages/pytrainer/upgrade/migratedb.py", line 19, in <module>
from migrate.versioning.api import db_version, upgrade, version, version_control
File "/usr/lib/python2.7/site-packages/migrate/versioning/api.py", line 33, in <module>
from migrate.versioning import (repository, schema, version,
File "/usr/lib/python2.7/site-packages/migrate/versioning/repository.py", line 9, in <module>
from pkg_resources import resource_filename
ImportError: No module named pkg_resources
[chris@myhost ~]$

xduugu commented on 2011-12-16 23:40

Seems that python2-distribute dependency is missing...
Thanks.

zoe commented on 2011-12-16 23:33

When executed, I got an error :

[chris@myhost ~]$ pytrainer
running pytrainer from egg installation
data_path: /usr/share/pytrainer/
gettext_path: /usr/share/locale
site_path: /usr/share/lib/python2.7/site-packages
Traceback (most recent call last):
File "pytrainer", line 96, in <module>
from pytrainer.main import pyTrainer
File "/usr/lib/python2.7/site-packages/pytrainer/main.py", line 36, in <module>
from upgrade.data import initialize_data
File "/usr/lib/python2.7/site-packages/pytrainer/upgrade/data.py", line 23, in <module>
from pytrainer.upgrade.migratedb import MigratableDb
File "/usr/lib/python2.7/site-packages/pytrainer/upgrade/migratedb.py", line 19, in <module>
from migrate.versioning.api import db_version, upgrade, version, version_control
File "/usr/lib/python2.7/site-packages/migrate/versioning/api.py", line 33, in <module>
from migrate.versioning import (repository, schema, version,
File "/usr/lib/python2.7/site-packages/migrate/versioning/repository.py", line 9, in <module>
from pkg_resources import resource_filename
ImportError: No module named pkg_resources
[chris@myhost ~]$

xduugu commented on 2011-12-02 10:40

Ok, adjusted {md5,sha256}sums. They just fixed the version number (was 1.9.2-dev before instead of 1.9.1).

xduugu commented on 2011-12-02 10:32

They replaced the source tarball three days ago. I will check the differences to the old one and update the PKGBUILD if it is fine. Thanks for pointing out.

lantald commented on 2011-12-02 10:29

The MD5sum and the SHA256sum fail. They might belong to the previous version?