Package Details: python38 3.8.12-1

Git Clone URL: https://aur.archlinux.org/python38.git (read-only, click to copy)
Package Base: python38
Description: Major release 3.8 of the Python high-level programming language
Upstream URL: https://www.python.org/
Keywords: python python3
Licenses: custom
Provides: python
Submitter: rixx
Maintainer: rixx
Last Packager: rixx
Votes: 18
Popularity: 0.57
First Submitted: 2019-03-27 20:21
Last Updated: 2021-08-30 23:08

Required by (1000)

Sources (3)

Pinned Comments

NGeorgescu commented on 2021-06-21 20:43

If you get a no-name pgp key error, try:

gpg --keyserver keyserver.ubuntu.com --recv-keys E3FF2839C048B25C084DEBE9B26995E310250568

Latest Comments

« First ‹ Previous 1 2

rokyfox commented on 2021-02-07 15:46

How do I access pip?

I tried python3.8 -m pip but it just says /usr/bin/python3.8: No module named pip

edit: Turns out python3.8 -m venv works, and the virtualenv comes with pip. Would have liked to not need an environment though.

falstaff_ch commented on 2020-12-09 20:01

@max-k python3.8 --version showed 3.9.0 today for me too, and I was wondering. But I realized I was in a venv which I created back when python was python3.8.

max-k commented on 2020-12-03 20:26

I don't reproduce it on another system. Thank you anyway.

python3.8 --version
Python 3.8.6

rixx commented on 2020-12-03 16:44

I can't reproduce that, sorry. I ran a complete system upgrade and installed python38, and am seeing the expected output:

python3.8 --version
Python 3.8.6

If you find the problem, please submit a patch with the fix.

max-k commented on 2020-12-03 15:09

Is there a problem ?

python3.8 --version
Python 3.9.0

harbind commented on 2020-12-03 08:28

python3.8-config does not work. It's a symlink to unexciting python3.8m-config.

rixx commented on 2019-06-05 10:18

I don't agree on the --enable-optimizations and --with-lto options: While they do improve Python speed noticeably, they also add considerable build time (think tens of minutes, at least, can range into an hour easily). I don't want the general Python 3.8 package to take this long to build – mainstream does not have the issue because the package is not built on every upgrade on every PC.

I fixed the failing symlinks, though, nd upgraded to 3.8.0b1

RunAndTumble commented on 2019-05-14 16:33

OK, when I try to build a4 version, first, I get this: configure: WARNING: unrecognized options: --with-threads However, it doesn't affect the process. The other problem is that it throws another error: ln: failed to create symbolic link '/home/user/build/python38/pkg/python38/usr/lib/python3.8/config-3.8m-x86_64-linux-gnu/libpython3.8m.so': No such file or directory and stops completely. Any ideas how to fix this?

P.S. It would be great to add --enable-optimizations and --with-lto as build parameters (python3.7 mainstream PKGBUILD has some detailed instructions).

rixx commented on 2019-04-25 12:36

Good point, I updated the URL.

zeust commented on 2019-04-25 10:25

Great package, works like a charm and does not conflict with Python stable! I do see that the upstream URL and the source download URL are still HTTP, it is better to change them to HTTPS. I did this myself locally before building the package (in both the PKGBUILD and the .SRCINFO) and can confirm that it works.