Package Details: python2-wnck 2.32.0-20

Git Clone URL: https://aur.archlinux.org/gnome-python-desktop.git (read-only, click to copy)
Package Base: gnome-python-desktop
Description: Python bindings for libwnck
Upstream URL: https://www.gnome.org
Licenses: GPL, LGPL
Conflicts: python-wnck<=2.32.0-10
Replaces: python-wnck<=2.32.0-10
Submitter: twa022
Maintainer: None
Last Packager: twa022
Votes: 4
Popularity: 0.000970
First Submitted: 2019-06-23 01:34
Last Updated: 2020-01-18 19:23

Latest Comments

1 2 Next › Last »

Icecube63 commented on 2020-01-22 08:55

I get a mistake with the checksum while upgrading:

==> Überprüfe source Dateien mit sha256sums... gnome-python-desktop-2.32.0.tar.bz2 ... FEHLGESCHLAGEN 01_wnck_enums.patch ... Durchgelaufen ==> FEHLER: Eine oder mehrere Dateien überstanden nicht die Gültigkeits-Prüfung!

yannleretaille commented on 2020-01-14 16:32

confirming this is still an issue and that adding --disable-evolution --disable-evolution_ecal does indeed fix it

link to updated PKGBUILD: https://gist.github.com/yannleretaille/298986fabf8279420243225fe8c1d175

amadej commented on 2019-09-24 15:02

@twa022 look like the following suggestion should be committed to the repo. https://aur.archlinux.org/pkgbase/gnome-python-desktop/#comment-700720

however, the repo is read-only...

vagelis commented on 2019-08-24 08:02

@petervrs thanx for the tip. Worked fine

JohnRobson commented on 2019-08-10 14:20

evo-ecal-environment.c:54:29: error: unknown type name ‘ESourceList’; did you mean ‘ESourceLDAP’?
   54 | evo_environment_find_source(ESourceList *list, const char *uri)
      |                             ^~~~~~~~~~~
      |                             ESourceLDAP
evo-calendar.c: In function ‘evo_cal_component_set_modified’:
evo-calendar.c:242:10: warning: implicit declaration of function ‘icaltime_from_timet’; did you mean ‘icaltime_as_timet’? [-Wimplicit-function-declaration]
  242 |     tt = icaltime_from_timet(seconds, TRUE);
      |          ^~~~~~~~~~~~~~~~~~~
      |          icaltime_as_timet
evo-calendar.c:242:10: error: incompatible types when assigning to type ‘struct icaltimetype’ from type ‘int’
make[2]: *** [Makefile:503: ecal_la-evo-ecal-environment.lo] Error 1
make[2]: *** [Makefile:510: ecal_la-evo-calendar.lo] Error 1
make[2]: Leaving directory '/tmp/yay/gnome-python-desktop/src/gnome-python-desktop-2.32.0/evolution'
make[1]: *** [Makefile:511: all-recursive] Error 1
make[1]: Leaving directory '/tmp/yay/gnome-python-desktop/src/gnome-python-desktop-2.32.0'
make: *** [Makefile:380: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
Error making: gnome-python-desktop (python2-wnck)

jm09 commented on 2019-07-19 18:47

@Striffly I edited that file, but its get overwritten the next time I run pacaur -Su

petervrs commented on 2019-07-17 08:34

@Striffly Great that worked! Thank you!

Striffly commented on 2019-07-16 09:06

@petervrs @jm09, edit your PKGBUILD file like this :

PYTHON=/usr/bin/python2 ./configure --prefix=/usr --disable-metacity --disable-evolution --disable-evolution_ecal

petervrs commented on 2019-07-15 14:38

Would like to know too where --disable-evolution --disable-evolution_ecal should be configured.

jm09 commented on 2019-07-14 16:28

where exactly do you add?

--disable-evolution --disable-evolution_ecal