Package Details: python2-vpython 6.11-3

Git Clone URL: https://aur.archlinux.org/python2-vpython.git (read-only, click to copy)
Package Base: python2-vpython
Description: Easy-to-use 3D graphics module for Python.
Upstream URL: http://www.vpython.org
Licenses: custom
Conflicts: python-vpython
Replaces: python-vpython
Submitter: giniu
Maintainer: moyamo
Last Packager: moyamo
Votes: 23
Popularity: 0.000000
First Submitted: 2014-01-31 14:38
Last Updated: 2017-10-12 06:47

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Anonymous comment on 2011-10-31 22:53

The MD5 signature seems wrong. Should be:

b63a347f913130667565f301bde5fbcb

Anonymous comment on 2011-09-16 00:11

oh!
I got it, they are in the tarball above!

Anonymous comment on 2011-09-16 00:10

==> ERROR: idle.patch was not found in the build directory and is not a URL.

I see the boostmt.patch and idle.patch above in the "Sources" list, but where can I get them?

and also in the file PKGBUILD line 15:
source=(http://www.vpython.org/contents/download/visual-${pkg ver}_release.tar.bz2
16 idle.patch boostmt.patch)


thank you dear, I am new to arch...

giniu commented on 2011-09-09 10:12

I ported boost 1.47 compatibility fix from Fedora package, should do the trick.

giniu commented on 2011-08-31 11:35

True, it's because of update to boost 1.47. They changed a lot in their random library, including renames and implementation changes. I believe upstream will have to take action. Redhat has same problem: https://bugzilla.redhat.com/show_bug.cgi?id=725194

If I find a way to fix it, or someone from other distro or upstream will do it, I will add the patch as well. For now if you want to use vpython, stick to boost 1.46. I updated boost dependency to say boost<1.47 for now, sorry.

Anonymous comment on 2011-08-31 11:10

I got the same error as mdschech got yesterday.
The cause is that the boost and boost-lib packages went from version 46 to 47.
I downgraded to 46 and vpython works again.

Anonymous comment on 2011-08-30 23:01

I get the following error while compiling:

Compiling ./gtk2/random_device.cpp ...
make[1]: *** [random_device.lo] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-matt/aur-python-vpython/src/visual-5.71_release/src'
make: *** [all-recursive] Error 1

From build.log:

./gtk2/random_device.cpp:30:63: error: ‘const result_type boost::random::random_device::min_value’ is not a static member of ‘class boost::random::random_device’
./gtk2/random_device.cpp:30:41: error: uninitialized const ‘boost::random::random_device::min_value’ [-fpermissive]
./gtk2/random_device.cpp:31:63: error: ‘const result_type boost::random::random_device::max_value’ is not a static member of ‘class boost::random::random_device’
./gtk2/random_device.cpp:31:41: error: uninitialized const ‘boost::random::random_device::max_value’ [-fpermissive]
./gtk2/random_device.cpp:39:42: error: ‘const char* const boost::random::random_device::default_token’ is not a static member of ‘class boost::random::random_device’

giniu commented on 2011-07-03 10:53

@schmidtbag: can you try current version?

schmidtbag commented on 2011-06-16 16:53

I'm not able to compile this either, I get the same cvisialmodule.la issue as hiato

giniu commented on 2011-05-21 17:59

fonttools package is now up to date, looks like we have fully functional vpython again