Package Details: python2-vpython 6.11-3

Git Clone URL: https://aur.archlinux.org/python2-vpython.git (read-only, click to copy)
Package Base: python2-vpython
Description: Easy-to-use 3D graphics module for Python.
Upstream URL: http://www.vpython.org
Licenses: custom
Conflicts: python-vpython
Replaces: python-vpython
Submitter: giniu
Maintainer: moyamo
Last Packager: moyamo
Votes: 23
Popularity: 0.000000
First Submitted: 2014-01-31 14:38
Last Updated: 2017-10-12 06:47

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

mefistofeles commented on 2012-04-03 03:20

I installed python-vpython succesfully, though when I try to import visual module in a python shell I get
ImportError: libboost_python.so.1.48.0: cannot open shared object file: No such file or directory

Any ideas?
Thanks.

Hspak commented on 2012-01-12 04:11

The error doesn't exist. I was trying to build the package in a tmpfs mount where I mounted it with 'noexec.' Silly me.

giniu commented on 2012-01-11 06:54

This definitely shouldn't happen - can you try to run the ./configure script in source tree from command line? What are the permissions of the ./configure file in src tree?

Hspak commented on 2012-01-10 21:32

I am getting some permission error in build.
--


==> Starting build()...
patching file bin/vpython.in
patching file src/gtk2/makefile
/home/hsp/.aur/python-vpython/PKGBUILD: line 34: ./configure: Permission denied

giniu commented on 2011-12-17 12:33

I just checked to be sure and yes, they changed the archive week ago, more than month after releasing if for the first time...

giniu commented on 2011-12-16 22:03

I don't believe it, they changed source third time without version bump? :| Ehh... anyway, thanks for noticing, I will fix it tomorrow.

andrej84 commented on 2011-12-15 21:24

Getting this error:

-> Downloading visual-5.72_release.tar.bz2...
--2011-12-15 21:11:03-- http://www.vpython.org/contents/download/visual-5.72_release.tar.bz2
Resolving www.vpython.org... 66.39.73.110
Connecting to www.vpython.org|66.39.73.110|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5757525 (5.5M) [application/x-tar]
Saving to: `visual-5.72_release.tar.bz2.part'

100%[===================================================================================================================>] 5,757,525 345K/s in 48s

2011-12-15 21:12:00 (117 KB/s) - `visual-5.72_release.tar.bz2.part' saved [5757525/5757525]

-> Found idle.patch
-> Found boostmt.patch
==> Validating source files with md5sums...
visual-5.72_release.tar.bz2 ... FAILED
idle.patch ... Passed
boostmt.patch ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build python-vpython.
==> Restart building python-vpython ? [y/N]
==> ---------------------------------------
==>
==> WARNING: Following packages have not been installed:
python-vpython

giniu commented on 2011-11-01 11:19

Sorry, no Python 3 support until fonttools gets Python 3 support as official (VPython folks post modified, unofficial patch for it on their page, but it works with Python 3.1 only) - there is already some work on it, i.e. I modified the VPython patched version to support fonttools 2.3 and Python 2.7 and 3.2 at once, and sent it upstream to fonttools developer, but the patch does not work on current trunk svn. We are right now looking into integrating it - you can follow the progress on https://sourceforge.net/tracker/?func=detail&aid=2627144&group_id=29196&atid=395372

After there will be python 3 enabled fonttools, this package will become python 3 based, and there will be new python2-vpython package. For now I did not wanted to bother with package rename when python 3 support is coming (keep in mind this package was uploaded not by me, and in time when python 2 was official. I'm aware it needs rename sooner or later, but I believe it's not the time yet).

mrbit commented on 2011-11-01 07:38

python3 ?????

giniu commented on 2011-10-31 23:45

Seems they changed the archive without notifying. Current one was uploaded on 24'th Oct, and I updated the package to 5.72 on 23'th. I will check what changed and update md5 tomorrow. Thanks for noticing it (man, how I hate when upstream replaces packages without version bump!)