Package Details: python2-vpython 6.11-3

Git Clone URL: https://aur.archlinux.org/python2-vpython.git (read-only, click to copy)
Package Base: python2-vpython
Description: Easy-to-use 3D graphics module for Python.
Upstream URL: http://www.vpython.org
Licenses: custom
Conflicts: python-vpython
Replaces: python-vpython
Submitter: giniu
Maintainer: moyamo
Last Packager: moyamo
Votes: 23
Popularity: 0.000000
First Submitted: 2014-01-31 14:38
Last Updated: 2017-10-12 06:47

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

giniu commented on 2013-04-13 19:06

VPython 6 requires wxpython>=2.9.4.1 - now talk about painful dependencies...

giniu commented on 2013-03-01 12:03

VPython 6 is relased, but it requires version 2.9 of wxpython, and not even latest but patched. It will take some time before we can update VPython to v6. I'm leaving this as out-of-date as a remainder.

required wxpython patch: https://groups.google.com/forum/?fromgroups=#!topic/wxpython-users/e27JioMs1fs

Anonymous comment on 2012-07-09 21:48

Thanks, I'll give it a go tomorrow. :D

giniu commented on 2012-07-09 08:52

I see (and also managed to replicate). There is not much we can do about it, this is issue of boost. There is workaround for this on forum which requires editing of one header file:

https://bbs.archlinux.org/viewtopic.php?pid=1126434

Anonymous comment on 2012-07-09 08:39

Here you are.

http://pastebin.com/zKPecSyM

Thanks for your help.

giniu commented on 2012-07-07 19:39

Strange. Can you post $srcdir/visual-5.74_release/src/build.log somewhere? It will give me a lot more detail to start with.

Anonymous comment on 2012-07-07 09:05

I am getting a build error:

make[1]: Entering directory `/tmp/pacaurtmp-nabobalis/python-vpython/src/visual-5.74_release/site-packages/visual'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/pacaurtmp-nabobalis/python-vpython/src/visual-5.74_release/site-packages/visual'
Making all in site-packages/vis
make[1]: Entering directory `/tmp/pacaurtmp-nabobalis/python-vpython/src/visual-5.74_release/site-packages/vis'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/pacaurtmp-nabobalis/python-vpython/src/visual-5.74_release/site-packages/vis'
Making all in src
make[1]: Entering directory `/tmp/pacaurtmp-nabobalis/python-vpython/src/visual-5.74_release/src'
Compiling ./core/util/atomic_queue.cpp ...
make[1]: *** [atomic_queue.lo] Error 1
make[1]: Leaving directory `/tmp/pacaurtmp-nabobalis/python-vpython/src/visual-5.74_release/src'
make: *** [all-recursive] Error 1
==> ERROR: A failure occurred in build().

Any more information I can give to in order to help?

giniu commented on 2012-04-07 08:41

The problem is that it does not work with python 3. Well, there is no problem with vpython itself. The problem is with fonttools which is one of dependencies. vpython guys publish unofficial patch. I sent the patch to fonttools developer but he found that there are issues with it. He is working on better solution. I do not want to patch fonttools with unofficial stuff with issues, that's why there is no python 3 version of fonttools, no python 3 version of ttfquery and thus no python 3 version of vpython.

Because there cannot be python 3 version of vpython, I did not removed this package and did not created python2-vpython. I am aware about the problem, but for now it is not worth it in my opinion. In extra there are also some python-* named python2-* packages that do not have python 3 versions yet, just like vpython.

So in short if you want python 3 version of vpython, ask fonttools developer about python 3 support :)

grimboy commented on 2012-04-07 06:54

VPython is compatible with Python 3 and Python 3 is the default on Arch therefore this package should install for Python 3 and there should be a new package python2-vpython for the python 2 version. Thanks.

giniu commented on 2012-04-03 06:06

(just as a note - if you get info about boost 1.48 not found - it means you need rebuild as boost is now 1.49)