Package Details: python2-thrift 0.13.0-1

Git Clone URL: https://aur.archlinux.org/python-thrift.git (read-only, click to copy)
Package Base: python-thrift
Description: Python bindings for the Apache Thrift RPC system
Upstream URL: https://thrift.apache.org/
Licenses: Apache
Submitter: anatolik
Maintainer: anatolik
Last Packager: anatolik
Votes: 23
Popularity: 0.72
First Submitted: 2017-11-27 00:44
Last Updated: 2019-10-31 12:43

Latest Comments

karcher commented on 2019-10-31 10:15

I'm getting this error during update:

==> Making package: python-thrift 0.13.0-1 (Thu 31 Oct 2019 11:13:52 AM CET)
==> Retrieving sources...
  -> Found thrift-0.13.0.zip
==> Validating source files with sha256sums...
    thrift-0.13.0.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!
Error downloading sources: python-thrift (python2-thrift)

anatolik commented on 2018-01-05 23:34

Thank you, liujed. Added your changes to the package.

liujed commented on 2018-01-05 23:16

anatolik: Updated PKGBUILD here - https://gist.github.com/liujed/8a9676fca8e3cbd5db6636984079b033

anatolik commented on 2017-11-22 00:29

Guillaume, it sounds good to me. Please upload your PKGBUILD as a new package and then I request merge of python2-thrift into python-thrift.

thrasibule commented on 2017-11-21 20:27

On top of being out of date, this package should be a split package with support for python3 as well. I have updated it here: https://gist.github.com/f7a3f022ad5ce65554ecce084f9e5dd9
After this change, package should be renamed to python-thrift.

anatolik commented on 2014-11-05 17:14

Merging it into python2-thrift

anatolik commented on 2014-11-03 18:07

Instead of compiling thrift sources this language binding should be using pip package from https://pypi.python.org/pypi/thrift

And it should be named python2-thrift instead.