Package Details: python2-sip-pyqt4 4.19.16-2

Git Clone URL: https://aur.archlinux.org/python-sip-pyqt4.git (read-only)
Package Base: python-sip-pyqt4
Description: Python 2.x SIP bindings for C and C++ libraries (PyQt4 version)
Upstream URL: http://www.riverbankcomputing.com/software/sip/intro
Licenses: custom:"sip"
Submitter: graysky
Maintainer: buzo
Last Packager: buzo
Votes: 29
Popularity: 2.56
First Submitted: 2019-01-06 15:57
Last Updated: 2019-05-25 09:09

Latest Comments

1 2 Next › Last »

dmp1ce commented on 2019-09-16 16:53

@Mechanical_Man python-pyqt4 has a "make" dependency on python-sip-pyqt4 and python2-sip-pyqt4. I think you just install the one you need.

Mechanical_Man commented on 2019-09-10 19:25

I'm not super familiar with internal package stuff at this point, so forgive me if I'm missing something obvious. :)

I'm trying to install a package (python-pyqt4) that depends on both python-sip-pyqt4 and python2-sip-pyqt4. However, it appears both of these packages install some of the same files:

/usr/lib/python2.7/site-packages/PyQt4/sip.pyi exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'
/usr/lib/python2.7/site-packages/PyQt4/sip.so exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'
/usr/lib/python2.7/site-packages/PyQt4_sip-4.19.16.dist-info/INSTALLER exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'
/usr/lib/python2.7/site-packages/PyQt4_sip-4.19.16.dist-info/METADATA exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'
/usr/lib/python2.7/site-packages/PyQt4_sip-4.19.16.dist-info/RECORD exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'

buzo commented on 2019-05-25 09:10

quequotion: fixed, thanks

quequotion commented on 2019-05-24 17:49

==> ERROR: pkgbase should not be an array

pkgbase can only have one value, so it doesn't need the parenthesis (they define the variable as an array, even if it only contains a single value).

pkgbase='python-sip-pyqt4'

buzo commented on 2019-05-01 10:54

Morganamilo, jvandrew: Sorry, I didn't notice that – fixed.

jvandrew commented on 2019-04-30 14:07

@buzo Understood. What caused the issue (according to yay maintainers) was changing the pkgbuild without bumping the pkgrel.

At any rate, if anyone reading this is having the same issue with yay, the fix is to do a "clean build".

Morganamilo commented on 2019-04-30 13:09

I do try to tell people not to seek support on the AUR if they are not just using makepkg.

But just for reference, yay bugs out because you never updated the pkgrel: https://aur.archlinux.org/cgit/aur.git/commit/PKGBUILD?h=python-sip-pyqt4

rezaarifandee commented on 2019-04-28 07:04

i can't download from riverbankcomputing, heck i cant even open their website. Anybody got a mirror for sip-4.19.16.tar.gz?

Edit: Found a mirror on https://src.fedoraproject.org/lookaside/pkgs/sip/sip-4.19.16.tar.gz/sha512/6a4e3e8580e914544c9037db61ab9cf05e2460cf2dbdeb67d30c949aa150952d2bb337061f7c7a9222251b04f83a1db1554ff576c3e83b8f60851b442133befa/sip-4.19.16.tar.gz

buzo commented on 2019-04-20 18:49

jvandrew: Please note that AUR helpers are not supported. You should try to get help from the yay developers, or just learn how to build manually (which works fine, btw).

jvandrew commented on 2019-04-20 18:08

Installing with yay, I get this error:

Could not find PKGDEST for: python2-sip-pyqt4

I assume this has something to do with the merger of this package into python-sip-pyqt4? This prevents updating pyqt4-common as well.