Package Details: python2-pythonmagick 0.9.19-1

Git Clone URL: https://aur.archlinux.org/python2-pythonmagick.git (read-only, click to copy)
Package Base: python2-pythonmagick
Description: Object-oriented Python2 bindings for the ImageMagick library
Upstream URL: http://www.imagemagick.org/
Licenses: custom
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 17
Popularity: 0.000000
First Submitted: 2011-06-22 18:18
Last Updated: 2018-01-28 21:50

Latest Comments

« First ‹ Previous 1 2

blablubb1234 commented on 2014-10-17 07:07

Hi, which boost do I need for pythonmagick to work? Is it boost from the official repository or <a href="https://aur.archlinux.org/packages/py%2B%2B/">py++</a> from the AUR?

blablubb1234 commented on 2014-10-17 07:06

Hi, which boost do I need for pythonmagick to work? Is it boost from the official repository or <href="https://aur.archlinux.org/packages/py%2B%2B/">py++</a> from the AUR?

joseywales72 commented on 2013-12-23 14:49

Hi, python2-magick cannot be installed on neither 32 nor 64 bit Archlinux. It gives this error and stops.
In file included from /usr/include/boost/python.hpp:18:0,
from _Image.cpp:3:
/usr/include/boost/python/class.hpp:266:11: note: template<class Fn, class A1, class A2, class A3> boost::python::class_<T, X1, X2, X3>::self& boost::python::class_<T, X1, X2, X3>::def(const char*, Fn, const A1&, const A2&, const A3&) [with Fn = Fn; A1 = A1; A2 = A2; A3 = A3; W = Magick::Image; X1 = boost::python::detail::not_specified; X2 = boost::python::detail::not_specified; X3 = boost::python::detail::not_specified]
self& def(char const* name, Fn fn, A1 const& a1, A2 const& a2, A3 const& a3)
^
/usr/include/boost/python/class.hpp:266:11: note: template argument deduction/substitution failed:
_Image.cpp:96:48: note: candidate expects 5 arguments, 2 provided
.def("compare", &Magick::Image::compare)
^
Makefile:745: recipe for target 'libpymagick_la-_Image.lo' failed
make[1]: *** [libpymagick_la-_Image.lo] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-anil/aur-python2-pythonmagick/src/PythonMagick-0.9.8/pythonmagick_src'
Makefile:639: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1

mustafakilic commented on 2012-03-22 20:27

Thanks

mschu commented on 2012-03-22 17:40

This is clearly a bug in pythonmagick that the devs introduced with their latest changes. I added a workaround, should be fine for now.

mustafakilic commented on 2012-03-22 16:18

Preparing to preconfigure pythonmagick
checking for aclocal version >= 1.10 ... 1.11.3 yes - (/usr/bin/aclocal)
checking for autoheader version >= 2.61 ... 2.68 yes - (/usr/bin/autoheader)
checking for libtoolize version >= 1.5.22 ... 2.4.2 yes - (/usr/bin/libtoolize)
checking for automake version >= 1.10 ... 1.11.3 yes - (/usr/bin/automake)
checking for autoconf version >= 2.61 ... 2.68 yes - (/usr/bin/autoconf)
executing /usr/bin/aclocal --force -I m4
executing /usr/bin/autoheader --force
executing /usr/bin/libtoolize --force --copy
executing /usr/bin/automake --add-missing --copy --force --include-deps --foreign
configure.ac:37: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2591: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2607: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:606: AS_IF is expanded from...
../../lib/autoconf/general.m4:2032: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2053: AC_CACHE_CHECK is expanded from...
m4/ax_boost_python.m4:58: AX_BOOST_PYTHON is expanded from...
configure.ac:37: the top level
Makefile.am:1: option `silent-rules' can only be used as argument to AM_INIT_AUTOMAKE
Makefile.am:1: but not in AUTOMAKE_OPTIONS makefile statements
==> HATA: build() içinde bir hata oluştu.
Çıkılıyor...
The build failed.

Anonymous comment on 2011-12-27 03:07

Checksums seem to be invalid. This one works:

md5sums=('fb5c88b7f0c93b4c32c3e66314cd86e5')