Package Details: python2-llvmlite 0.29.0-1

Git Clone URL: https://aur.archlinux.org/python2-llvmlite.git (read-only)
Package Base: python2-llvmlite
Description: Lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 7
Popularity: 0.273493
First Submitted: 2014-12-29 17:25
Last Updated: 2019-05-31 07:00

Latest Comments

1 2 Next › Last »

xantares commented on 2019-01-09 20:28

hello,

could you check the checksum, I believe it's incorrect

regards

mschu commented on 2016-08-03 21:05

llvm=3.8 is supported from 0.13, which is currently a dev release.

For python2-llvmlite, I will stick with the stable releases.

If you want to use the latest llvmlite, try the python2-llvmlite-git package (and report bugs there).

leepesjee commented on 2016-07-24 18:26

I tried to compile version 0.12 with llvm-3.8.0 (which should be possible according https://github.com/numba/llvmlite), but could not make this work,
due to llvm compatibility issues.

mschu commented on 2016-03-01 20:46

0.9.0 now working with llvm-3.7.x

mschu commented on 2016-01-11 23:38

That is, unfortunately, unavoidable.

You can either not have updated (too late for this) or use an older PKGBUILD from llvm (just check the git archive) to rebuild it - or wait until llvmlite supports llvm=3.7.x

kdre commented on 2016-01-11 20:34

I get the following error:

==> Install or build missing dependencies for python2-llvmlite:
error: target not found: llvm<3.7.0

There doesn't seems to be a package for llvm 3.6. How to install it?

BTW: As a consequence python2-numba cannot be installed. On the other side: Beignet depends on llvm 3.7. A vicious circle...

efzee commented on 2015-12-22 00:42

I am getting the following error
:: resolving dependencies...
:: no results found for llvm<3.7.0

How can I install llvm < 3.7 from the repos?

Thanks in advance

mschu commented on 2015-08-07 15:08

updated, and removed enum34 from python2-numba

berquist commented on 2015-08-07 15:03

`python2-enum34` should be added as a dependency:

==> Validating source files with md5sums...
v0.6.0.tar.gz ... Passed
==> Extracting sources...
-> Extracting v0.6.0.tar.gz with bsdtar
==> Starting build()...
Traceback (most recent call last):
File "setup.py", line 19, in <module>
from llvmlite.utils import get_library_files
File "/home/eric/Downloads/AUR/python2-llvmlite/src/llvmlite-0.6.0/llvmlite/__init__.py", line 6, in <module>
raise ImportError("could not find the 'enum' module; please install "
ImportError: could not find the 'enum' module; please install it using e.g. 'pip install enum34'
==> ERROR: A failure occurred in build().
Aborting...

jyantis commented on 2015-01-21 01:33

=> Validating source files with md5sums...
v0.2.1.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!