Package Details: python2-jenkinsapi 0.3.11-1

Git Clone URL: https://aur.archlinux.org/python-jenkinsapi.git (read-only, click to copy)
Package Base: python-jenkinsapi
Description: Python API for accessing resources on a Jenkins continuous-integration server
Upstream URL: https://github.com/pycontribs/jenkinsapi
Keywords: jenkins jenkinsapi python python2
Licenses: MIT
Submitter: moscar
Maintainer: DuckSoft
Last Packager: TrialnError
Votes: 1
Popularity: 0.23
First Submitted: 2017-01-12 19:16
Last Updated: 2020-01-17 21:16

Latest Comments

moscar commented on 2017-08-08 17:57

Hmm, that's weird. I build this on my CI system which has a clean Archlinux install for every build.

Tahvok commented on 2017-08-08 15:11

makepkg (no options)
Here's the full output:
https://gist.github.com/Tahvok/e1834b34e431be8acb0fa3e53efc7704

I have created a -git package, because I really needed it in the meantime: https://aur.archlinux.org/packages/python-jenkinsapi-git

This works because the version is derived from git.

I'm not sure why you don't have any problems, I have a pretty clean system myself..

moscar commented on 2017-07-31 17:16

@Tahvok How are you building this? I just tried to build it with `makepkg -is` and I don't see any issues.

Tahvok commented on 2017-07-31 12:40

Doesn't work:

Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. It's also possible that there is a mismatch between the package name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name jenkinsapi was given, but was not able to be found.
error in setup command: Error parsing /tmp/jenkinsapi-0.3.5/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. It's also possible that there is a mismatch between the package name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name jenkinsapi was given, but was not able to be found.