Package Details: python2-gimp 2.10.20-1

Git Clone URL: https://aur.archlinux.org/python2-gimp.git (read-only, click to copy)
Package Base: python2-gimp
Description: Python 2 plugins support for GIMP
Upstream URL: https://www.gimp.org/
Licenses: LGPL
Submitter: City-busz
Maintainer: ValHue
Last Packager: ValHue
Votes: 9
Popularity: 0.68
First Submitted: 2020-03-18 20:49
Last Updated: 2020-06-11 06:58

Latest Comments

1 2 Next › Last »

lasagnacrab commented on 2020-10-08 21:12

@ValHue I was able to install correctly. Not sure what the specific issue was, but I'll list below what measures I took incase anyone else hits this.

  • I had PhotoGIMP installed and thought that might be a point of failure, so I completely uninstalled GIMP and deleted configs

  • Updated pacman mirrors (was getting mirror errors when trying to do a clean GIMP install)

  • Updated all pacman and AUR packages

  • Reboot

  • Installed a clean GIMP with pacman

  • Installed python2-GIMP with yay - Installation successful!

  • Reinstall PhotoGIMP and other python plugins

  • Plugins work successfully

ValHue commented on 2020-10-07 16:56

@lasagnacrab: I try to reproduce the error and I can't. Indicate how you get it please.

lasagnacrab commented on 2020-10-05 18:06

Getting a python2 headers error. I'm able to locate my Python.h file in /usr/include/python2.7. I tried specifying a python version in ./configure, but no dice.

Error: GIMP configuration failed.

  - Python 2 headers
      *** Please install them, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).

See the file 'INSTALL' for more help.
==> ERROR: A failure occurred in build().
    Aborting...
error making: %!s(func() string=0x561728ed8a60)

promi commented on 2020-07-12 10:50

@damonh If you'r using gimp 2.10.18 Just download the previous PKGBUILD file and use command makepkg -s

Package Actions/ View Changes/ click on the previous commit to view it and click download to get the old PKGBUILD file, cd into the same directory where you uncompressed the file and use makepkg -s to make python2-gimp-2.10.18 package, after that install with pacman.

City-busz commented on 2020-07-05 08:26

@myriacore, @madjoe: make sure that you are using gimp, babl and gegl from the official repositories, and you system is up to date. The package should build fine in a clean chroot.

myriacore commented on 2020-07-04 15:56

Unsurprisingly, I'm getting the same issue as @madjoe and @damonh.

madjoe commented on 2020-06-29 20:00

Same babl gegl issue here. @ultraphaze, thanks for the tip.

damonh commented on 2020-06-28 17:12

It fails to me too:

Error: GIMP configuration failed.

  - Error: missing dependency babl >= 0.1.78
  - Error: missing dependency gegl-0.4 >= 0.4.24

See the file 'INSTALL' for more help.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: python2-gimp

ultraphaze commented on 2020-06-15 06:18

@ValHue, @maderios After some searches on the internet, I found out that it works with gegl-git babl-git. I have not installed the packages before because they show the wrong version numbers. They show babl-git-0.1.77.r1636.0ec7f09-1 gegl-git-0.4.23.r10019.d528f1541-1 but you get installed babl-git-0.1.79.r1641.e7e80bd-1 gegl-git-0.4.25.r10063.40da695ea-1. Anyway, in the meantime I found GMIC which is the better plugin collection so that I no longer need gimp-plugin-registry.

maderios commented on 2020-06-13 08:16

@ultraphaze "These boards are for the support of Arch Linux, and Arch ONLY. If you have installed Archbang, Antergos, Chakra, Evo/Lution, Manjaro, Whatever, you are NOT running Arch Linux" https://bbs.archlinux.org/viewtopic.php?id=130309