Package Details: python2-control 0.8.2-2

Git Clone URL: https://aur.archlinux.org/python-control.git (read-only, click to copy)
Package Base: python-control
Description: Implements basic operations for analysis and design of feedback control systems in Python
Upstream URL: https://github.com/python-control/python-control
Licenses: BSD
Submitter: calcmogul
Maintainer: calcmogul
Last Packager: calcmogul
Votes: 4
Popularity: 0.000000
First Submitted: 2015-09-05 22:38
Last Updated: 2019-10-04 05:05

Latest Comments

fernando_morais commented on 2019-11-03 14:06

m-pilia, the python2-scikit-build package maintainer, recommends the following workaround:

"As a workaround, since this seems to be only an issue with the pytest setup, you can delete or comment out the check() function from the PKGBUILD file" (of the python2-scikit-build package).

It worked and python-control installation was completed.

calcmogul commented on 2019-10-29 02:14

The PKGBUILD already depends on python-slycot as of this commit: https://aur.archlinux.org/cgit/aur.git/commit/?h=python-control&id=8d96210bb1c8

fernando_morais commented on 2019-10-29 01:29

@calcmogul: python2-scikit-build was updated on 2019-10-03. https://aur.archlinux.org/packages/python2-scikit-build/

calcmogul commented on 2019-09-29 03:54

python-slycot currently doesn't compile because python2-scikit-build doesn't exist (and that's been brought up in a comment on python-scikit-build). I'll update the dependency once that's fixed.

bnavigator commented on 2019-09-28 18:35

I made a PKGBUILD for python-slycot. python-control should depend on that instead of python-slycot-git

calcmogul commented on 2017-10-09 19:49

Have all of your dependencies been rebuilt for Python 3.6? That's the only cause I can think of. https://www.reddit.com/r/archlinux/comments/5mer2f/psa_rebuild_all_aur_packages_providing_python/

DCengineer commented on 2017-10-02 22:55

I've been getting an error in the unit tests. For now, I just skipped the tests, but this is not a permanent solution.

Test failed: <unittest.runner.TextTestResult run=190 errors=0 failures=1>

madmaurice commented on 2015-09-08 18:35

PKGBUILD Version 0.7.0-2 fails during tests because of missing slycot dependency:

Traceback (most recent call last):
File "/tmp/yaourt-tmp-xxx/aur-python-control/src/python-control-0.7.0/control/statesp.py", line 496, in minreal
from slycot import tb01pd
ImportError: No module named 'slycot'

Might want to add slycot as full dependency or at least check