Package Details: python-yarl-gns3 1.4.2-1

Git Clone URL: https://aur.archlinux.org/python-yarl-gns3.git (read-only, click to copy)
Package Base: python-yarl-gns3
Description: Yet another URL library (GNS3)
Upstream URL: https://github.com/aio-libs/yarl/
Licenses: Apache
Groups: gns3
Conflicts: python-yarl
Provides: python-yarl
Submitter: jnbrains
Maintainer: buzo
Last Packager: buzo
Votes: 12
Popularity: 0.000083
First Submitted: 2017-06-21 14:24
Last Updated: 2020-05-10 17:17

Required by (13)

Sources (1)

Latest Comments

1 2 Next › Last »

Gero commented on 2020-01-19 22:59

mahdilr: After applying my fixes you shouldn't be compiling this package (and therefore not have the error anymore) ;)

But as buzo confirmed, gns3 depends on fixed versions, so it was the wrong fix that just happened to work for now (since upstream arch is coincidentally the right version). This was also the reason I asked jnbrains what the right fix would be instead of publishing my changes.

Anyways, glad to hear it's working! I should be applying buzo's fix too, but I'll just wait until the issue is solved since I'm lazy xD

mahdilr commented on 2020-01-19 21:32

Gero;i applied your changes the problem persists, however i did the build without check like buzo motioned, and it working now, thanks you for your great help

buzo commented on 2020-01-18 14:36

KaiSVK: python-yarl is marked as outdated in community and should be updated to 1.4.2 soon. As mentioned by Gero, this package is locked to the version needed by gns3-server and gns3-gui.

buzo commented on 2020-01-18 14:29

Gero, mahdilr: This is an upstream bug. You can build with --nocheck to omit the buggy checks.

Gero commented on 2020-01-18 13:53

mahdilr: apparently I did xD found these changes to the gns3-server PKGBUILD on my machine locally:

diff --git a/PKGBUILD b/PKGBUILD
index 082082a..a0c097d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,10 +11,10 @@ url='https://github.com/GNS3/gns3-server'
 license=('GPL3')
 groups=('gns3')
 makedepends=('python-setuptools')
-depends=('python-jsonschema26' 'python-aiohttp-gns3' 'python-aiohttp-cors-gns3'
+depends=('python-jsonschema26' 'python-aiohttp' 'python-aiohttp-cors'
          'python-async_generator' 'python-aiofiles'
          'python-yarl' 'python-jinja' 'python-raven' 'python-psutil'
-         'python-zipstream-gns3' 'python-prompt_toolkit-gns3' 'python-async-timeout-gns3'
+         'python-zipstream' 'python-prompt_toolkit' 'python-async-timeout'
          'busybox')
 optdepends=('dynamips: Cisco router emulator.'
             'gns3-gui: graphical user interface for GNS3 server.'

@jnbrains can you judge whether this is an appropriate fix and get back to us?

mahdilr commented on 2020-01-18 12:55

Hello @Gero i'm having the same issue, did you resolve the problem

Gero commented on 2020-01-01 12:30

KaiSVK: See comment by jnbrains below: https://aur.archlinux.org/packages/python-yarl-gns3/#comment-629908

However, @jnbrains, is your comment still relevant? This package now does not build anymore due to below error:

==================================================================================================== FAILURES =====================================================================================================
___________________________________________________________________________________________ TestScheme.test_no_scheme1 ____________________________________________________________________________________________

self = <test_url_parsing.TestScheme object at 0x7f946695bc10>

    def test_no_scheme1(self):
        u = URL("google.com:80")
>       assert u.scheme == ""
E       AssertionError: assert 'google.com' == ''
E         - google.com

tests/test_url_parsing.py:43: AssertionError
==================================================================================== 1 failed, 856 passed, 8 xfailed in 3.18s =====================================================================================
==> ERROR: A failure occurred in check().
    Aborting...

KaiSVK commented on 2019-11-18 20:21

Hello,

What is different in python-yarl-gns3 vs. python-yarl (which is already on 1.3.0) ?

I install python-yarl 1.3.0 from repos and removed python-yarl-gns3 from PKBUILD in gns3-server. And it works.

Just asking

juliano.bn commented on 2019-11-17 22:51

Workaround to run GNS3 2.2.3:

Change PKGBUILD:

Generate package as usual: makepkg

Install with pacman -U python-yarl-gns3-1.3.0-1-any.pkg.tar.xz

leo95 commented on 2019-11-12 22:42

gns3-server 2.2.3-1 requires yarl=1.3.0, pkgver should be 1.3.0