Package Details: python-ueberzug 18.1.5-1

Git Clone URL: https://aur.archlinux.org/python-ueberzug.git (read-only)
Package Base: python-ueberzug
Description: ueberzug is an python script which aims to replace w3mimgdisplay
Upstream URL: https://github.com/seebye/ueberzug
Licenses: GPL
Conflicts: python-ueberzug-git
Submitter: arkhan
Maintainer: arkhan
Last Packager: arkhan
Votes: 7
Popularity: 1.69
First Submitted: 2018-11-15 13:44
Last Updated: 2019-11-06 02:40

Latest Comments

pepper_chico commented on 2019-08-04 07:05

This package is simply not working with python-pillow-simd (which seems broken). I had to remove it and python-pillow-simd and install python-pillow + python-ueberzug-nosimd-git instead. Problem fixed.

ks1c commented on 2019-07-02 14:23

Ueberzug is not working with python-pillow-simd 1:5.3.0.post1-2 for me, it keeps giving segmentation fault errors. After I downgraded to python-pillow-simd 1:5.3.0.post1-1, everything is working fine now.

FichteFoll commented on 2019-06-27 11:07

I would still like to suggest allowing to build the package with python-pillow, as this allows the host system more flexibility for e.g. testing. Since they use the same module names as python packages, ueberzug needn't worry about which version is actually being used, as long as the API is compatible.

I'll patch this locally for the time being.

python-pillow-simd could be made an optdep for discoverability.

FichteFoll commented on 2019-05-22 15:53

Does this actually require python-pillow-simd instead of python-pillow? The former provides the latter.

Edit: Apparently it does. On the upstream side and for performance reasons. https://github.com/seebye/ueberzug/commit/7a49f2ec75db95c325841c8eb6e8d643c9c92ab3

aeiou commented on 2019-04-01 13:39

It seems to require the package libimagequant, it didn't work until I installed that.

Kr1ss commented on 2019-02-28 14:15

This is not a 'git' package, but the source is pulled from the Github master branch. Could u pls fix this and pull the releases (atm 18.1.1). And, git is not really a valid version number, btw

EDIT Thanks for the quick update !

mehalter commented on 2019-01-24 18:54

python-docopt needs to be added to the dependencies. ueberzug crashes without it.