Package Details: python-tikzplotlib 0.9.16-1

Git Clone URL: https://aur.archlinux.org/python-tikzplotlib.git (read-only, click to copy)
Package Base: python-tikzplotlib
Description: Convert matplotlib figures into TikZ/PGFPlots
Upstream URL: https://github.com/nschloe/tikzplotlib
Licenses: MIT
Submitter: solnce
Maintainer: lmartinez-mirror
Last Packager: lmartinez-mirror
Votes: 5
Popularity: 0.000559
First Submitted: 2019-08-08 17:49
Last Updated: 2021-12-03 15:34

Latest Comments

1 2 Next › Last »

wcdawn commented on 2021-10-20 13:23

Works for me now. Thanks!

wcdawn commented on 2021-10-18 13:33

I'm installing with yay and get the following.

==> Making package: python-tikzplotlib 0.9.14-1 (Mon 18 Oct 2021 09:30:10 AM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Missing dependencies:
  -> python-pytest-runner
  -> python-pytest-randomly
==> ERROR: Could not resolve all dependencies.
 -> error making: python-tikzplotlib

At a minimum, python-pytest-runner and python-pytest-randomly need to be added as dependencies.

Three tests then fail with pytest.

===================================================== short test summary info ======================================================
FAILED tests/test_fillstyle.py::test - AssertionError: test_fillstyle_reference.tex
FAILED tests/test_colorbars.py::test - AssertionError: test_colorbars_reference.tex
FAILED tests/test_barchart_errorbars.py::test - AssertionError: test_barchart_errorbars_reference.tex

I can share more of the error messages but it is failing to compare the reference and output. It looks like it may be related to something in a new version of Matplotlib?

solnce commented on 2021-08-13 12:25

https://github.com/nschloe/tikzplotlib/pull/505

solnce commented on 2021-08-13 09:30

@carlosal1015 See https://wiki.archlinux.org/title/PKGBUILD#depends regarding transitive dependencies.

solnce commented on 2019-08-08 17:52

This library got renamed upstream, and I have requested to merge this package with the new package at https://aur.archlinux.org/packages/python-tikzplotlib.

The old package will not be updated anymore. Install the new package instead.

Anonymous comment on 2018-07-22 23:22

Thanks for renaming and updating!

solnce commented on 2018-07-22 18:23

@alleut: Good point. I have done this. This package is now obsolete and will be deleted in foreseeable future. Please use https://aur.archlinux.org/packages/python-matplotlib2tikz/

Anonymous comment on 2018-07-21 21:18

Maybe, it's worth renaming to 'python-matplotlib2tikz', similarly to other python packages?

solnce commented on 2018-04-14 08:09

There's a new maintainer for this package. Feel free to comment.

phcerdan commented on 2017-09-11 09:01

Please update dependencies: https://github.com/nschloe/matplotlib2tikz/blob/master/matplotlib2tikz/image.py

numpy, matplotlib, PIL (python-pillow).

Also, please update to avoid depending on pipdated: https://github.com/nschloe/matplotlib2tikz/blob/master/matplotlib2tikz/__init__.py