Package Details: python-spacy 2.3.2-1

Git Clone URL: https://aur.archlinux.org/python-spacy.git (read-only, click to copy)
Package Base: python-spacy
Description: Free open-source library for Natural Language Processing in Python
Upstream URL: https://spacy.io/
Licenses: MIT
Submitter: crendel
Maintainer: flipflop97
Last Packager: flipflop97
Votes: 3
Popularity: 1.52
First Submitted: 2018-10-30 09:39
Last Updated: 2020-09-28 20:49

Latest Comments

owenc1172 commented on 2020-06-15 17:49

@Jont828 Yes, I just got it after trying to compile a package. Anyone have a fix?

Jont828 commented on 2020-06-15 02:38

I've been getting the following error trying to upgrade to python-spacy-2.2.4. Is anyone else experiencing something similar?

Error compiling Cython file:
------------------------------------------------------------
...
        # and it doesn't matter that we create and discard the state objects.
        self.init_batch(docs)

        for doc in docs:
            beam = Beam(self.n_moves, beam_width, min_density=beam_density)
            beam.initialize(self.init_beam_state, self.del_beam_state,
                          ^
------------------------------------------------------------

transition_system.pyx:81:27: Call with wrong number of arguments (expected 4, got 5)
Traceback (most recent call last):
  File "/home/jont828/.cache/yay/python-spacy/src/spaCy-2.2.4/bin/cythonize.py", line 169, in <module>
    run(args.root)
  File "/home/jont828/.cache/yay/python-spacy/src/spaCy-2.2.4/bin/cythonize.py", line 158, in run
    process(base, filename, db)
  File "/home/jont828/.cache/yay/python-spacy/src/spaCy-2.2.4/bin/cythonize.py", line 124, in process
    preserve_cwd(base, process_pyx, root + ".pyx", root + ".cpp")
  File "/home/jont828/.cache/yay/python-spacy/src/spaCy-2.2.4/bin/cythonize.py", line 87, in preserve_cwd
    func(*args)
  File "/home/jont828/.cache/yay/python-spacy/src/spaCy-2.2.4/bin/cythonize.py", line 63, in process_pyx
    raise Exception("Cython failed")
Exception: Cython failed
Traceback (most recent call last):
  File "setup.py", line 200, in <module>
    setup_package()
  File "setup.py", line 188, in setup_package
    generate_cython(root, "spacy")
  File "setup.py", line 115, in generate_cython
    raise RuntimeError("Running cythonize failed")
RuntimeError: Running cythonize failed
==> ERROR: A failure occurred in package().
    Aborting...
error making: %!s(func() string=0x73a700)

crendel commented on 2020-05-04 03:29

Sure, sorry for the delay. Thanks for putting non-git repos up!

flipflop97 commented on 2020-01-21 11:53

It also imports and thus requires python-plac as a dependency. Can you add that one too?

flipflop97 commented on 2020-01-21 11:36

Hi, thanks for updating. Can you maybe change the dependencies python-srsly-git to python-srsly and python-wasabi-git to python-wasabi? Those are the stable versions that are also available in the AUR, and allows the user to choose between the two versions.

crendel commented on 2020-01-15 16:24

@flipflop97: this should now be fixed (it is for me) after updating spacy to 2.2.3 (including the other updated dependencies).

flipflop97 commented on 2020-01-07 10:54

I get an error while building this package, maybe updating the sources will fix it?

Cythonizing sources
Processing symbols.pyx
Processing parts_of_speech.pyx
Processing morphology.pyx

Error compiling Cython file:
------------------------------------------------------------
...
from cymem.cymem cimport Pool
from preshed.maps cimport PreshMapArray
^
------------------------------------------------------------

morphology.pxd:2:0: 'preshed/maps.pxd' not found
Traceback (most recent call last):
  File "/home/philip/.cache/yay/python-spacy/src/spaCy-2.1.3/bin/cythonize.py", line 169, in <module>
    run(args.root)
  File "/home/philip/.cache/yay/python-spacy/src/spaCy-2.1.3/bin/cythonize.py", line 158, in run
    process(base, filename, db)
  File "/home/philip/.cache/yay/python-spacy/src/spaCy-2.1.3/bin/cythonize.py", line 124, in process
    preserve_cwd(base, process_pyx, root + ".pyx", root + ".cpp")
  File "/home/philip/.cache/yay/python-spacy/src/spaCy-2.1.3/bin/cythonize.py", line 87, in preserve_cwd
    func(*args)
  File "/home/philip/.cache/yay/python-spacy/src/spaCy-2.1.3/bin/cythonize.py", line 63, in process_pyx
    raise Exception("Cython failed")
Exception: Cython failed
Traceback (most recent call last):
  File "setup.py", line 275, in <module>
    setup_package()
  File "setup.py", line 208, in setup_package
    generate_cython(root, "spacy")
  File "setup.py", line 131, in generate_cython
    raise RuntimeError("Running cythonize failed")
RuntimeError: Running cythonize failed