Package Details: python-snowboy-git v1.3.0.r31.g797a17e-1

Git Clone URL: https://aur.archlinux.org/python-snowboy-git.git (read-only)
Package Base: python-snowboy-git
Description: A hotword detection engine - Python bindings
Upstream URL: https://snowboy.kitt.ai/
Licenses: Apache
Conflicts: python-snowboy
Provides: python-snowboy
Submitter: aimileus
Maintainer: None
Last Packager: aimileus
Votes: 1
Popularity: 0.000023
First Submitted: 2018-01-24 18:36
Last Updated: 2018-05-11 11:57

Latest Comments

1 2 Next › Last »

NicoHood commented on 2018-05-11 12:51

Well, as long as it works its fine. Your choice.

aimileus commented on 2018-05-11 12:27

Fair enough, but most python packages in the official repositories, still don't include python as dependency. For example, extra/python-requests 2.18.4-1 only depends on python-urllib3, python-chardet and python-idna. Also the documentation on the depends array on the PKGBUILD ArchWiki page, suggests to leave out these dependencies. Also python-pyaudio will always depend on python, even if that package will be renamed for some reason.

NicoHood commented on 2018-05-11 12:18

That is true, but still not correct. It will pull in the dependency, but (even though it does not make lots of sense) it could be possible that pyaudio drops the python dependency and then the package will break. And because you know that the code of snowboy itself directly (also) depends on python, you need to add those as well. Another aspect is when the pyaudio dependency is dropped you need to add python as dependency, which means you were missing it in the first place. So the safe way is to include the dependencies as well here.

aimileus commented on 2018-05-11 11:58

@NicoHood, thanks, I've updated the conflicts and provides arrays.

Regarding the python/python2 dependency, what I meant was that python{,2}-pyaudio already depends on python{,2}, so it is not necessary to explicitly depend on python{,2} as well.

NicoHood commented on 2018-05-06 13:26

I noticed that you cannot install both python packages at the same time (2 and 3). You need to move the conflict() and provides() into the package functions and rename the one for python2. Then both packages can coexist.

NicoHood commented on 2018-05-04 12:54

@aimileus Sorry I missed to subscribe to the comments.

Isn't python/python2 is a redundant dependency?

No, as they are required to run the modules. If you check the package with namcap you will get a warning or error message. Lets say an application requires a python package XYZ with an executable script inside and the user has no python installed, the package is broken. (Example: pyserial with miniterm.py) Please add those again.

Shouldn't python2-snowboy depend on python2-pyaudio instead of python-pyaudio?

Correkt, good catch! I will fix my package.

aimileus commented on 2018-02-23 16:43

@NicoHood, thanks, I just added (most of) your tweaks. Only 2 questions:

  • Isn't python/python2 is a redundant dependency?
  • Shouldn't python2-snowboy depend on python2-pyaudio instead of python-pyaudio?

aimileus commented on 2018-02-23 15:47

@xantares, I didn't experience any problems, just referring to some potential problems that might appear (somehow my 'if' disappeared).

NicoHood commented on 2018-02-22 09:52

I've created a new package of the stable snowboy version. It can be found here: https://aur.archlinux.org/packages/python-snowboy

Check out the PKGBUILD, it has some tweaks which you could add to your package as well :)

xantares commented on 2018-02-20 14:53

Hi, what problems are you referring to? It seems to work on my side without atlas.