Package Details: python-seafobj 8.0.6-1

Git Clone URL: https://aur.archlinux.org/python-seafobj.git (read-only, click to copy)
Package Base: python-seafobj
Description: Python library for accessing seafile data model
Upstream URL: https://github.com/haiwen/seafobj
Licenses: Apache
Submitter: trap000d
Maintainer: trap000d
Last Packager: trap000d
Votes: 0
Popularity: 0.000000
First Submitted: 2020-06-01 00:02
Last Updated: 2021-07-28 08:11

Latest Comments

DanSman commented on 2020-12-08 04:08

I'm sorry for some reason my comment ended up in here. It was for python-wsgidav-seafile.

Anyhow, I deinstalled python-wheel and I installed python-wsgidav-seafile again and it works!

Thank you very much!

trap000d commented on 2020-12-08 01:41

Hi @DanSman, I've created fresh VM and tested Seafile and Seafdav installation in clean environment. Indeed, there are some missing dependencies, but not a 'python-wheel' - everything runs without this package.

So, to satisfy all them you need to install several extra packages:

sudo pacman -S python-defusedxml python-jinja python-sqlalchemy python-yaml

P.S. I've just pushed updated versions of python-seafobj and python-wsgidav-seafile to aur

trap000d commented on 2020-12-05 23:23

@DanSman, My Seafile server has running on ARM device where Python hasn't updated to 3.9 yet, so I had no chance to test it, unfortunately. If it will not appear in next few days, I'll set up an x86 VM with Arch to test all things.

This is from Seahub tread:

kuzalj commented on 2020-12-02 20:03

Just a reminder to everyone that might have some issues. Arch updated the Python packages in the repos to 3.9. This means any python packages you have installed need to be "recompiled" in order for any python depends to work, otherwise, you will get missing depends on errors.

IF you were running seafile with python 3.8 before, running this command will let you know what python packages haven't been recompiled yet and write it to a file.

sudo pacman -Qqo /usr/lib/python3.8/site-packages/* | sort -u > rebuild.txt

Then run this to reinstalll packages (clean the packages, make sure it does a clean rebuild)

yay -S - < rebuild.txt

I can confirm seafile is working with python 3.9. Enjoy!

DanSman commented on 2020-12-05 20:46

python-wheel packages is necessary for building.
But seafdav isn't working anyway. Couldn't figured out so far what the reason for that is. Probably the new python v 3.9.