Package Details: python-raspberry-gpio 0.7.0-2

Git Clone URL: https://aur.archlinux.org/python-raspberry-gpio.git (read-only, click to copy)
Package Base: python-raspberry-gpio
Description: Python library for GPIO access on a Raspberry Pi
Upstream URL: http://sourceforge.net/projects/raspberry-gpio-python
Licenses: MIT
Submitter: mickybart
Maintainer: mdevaev
Last Packager: mdevaev
Votes: 13
Popularity: 0.000008
First Submitted: 2013-05-11 19:27
Last Updated: 2020-09-11 15:20

Latest Comments

1 2 3 4 Next › Last »

JP-Undercover commented on 2020-09-12 22:41

@mdevaev Thanks for the clarification, I'm not quite experienced enough to feel like I could maintain a package, I'm just using it for the fanshim package, however there's an ongoing project that uses libgpiod as a replacement which unfortunately seems abandoned aswell.

However thanks to the last fix it's working as expected on my system. Thanks!

mdevaev commented on 2020-09-11 15:20

@Dark-Sky: thanks, fixed.

Dark-Sky commented on 2020-09-11 15:07

I marked this out of date but if these changes are made it seems it will work again.

Change: python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1

To:

env CFLAGS="-fcommon" python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1

Credit @wntr:

https://forum.manjaro.org/t/outdated-package-python-raspberry-gpio/24045/5

mdevaev commented on 2020-09-11 14:56

@JP-Undercover

I understand your dissatisfaction with the fact that I don't accept patches. I explained my position: there is no guarantee that this patch will not break something else, despite its simple content. I wouldn't mind handing over the maintenance of this package to someone else. Do you want to keep it?

As for the current state of RPi.GPIO: it seems that the original developer has lost interest in it and is not engaged in solving problems. You should also be aware that the sysfs kernel interface used by this module has long been deprecated and will soon be removed. Linux developers recommend using libgpiod, which works great and has bindings for C++ and Python. If you are interested in RPi.GPIO as a developer for your own projects, I advise you to switch to libgpiod. That's what I do for my things.

https://aur.archlinux.org/packages/libgpiod/

JP-Undercover commented on 2020-09-11 11:09

Okay you can ignore my latest post, and just as a warning to users running Manjaro ARM (I know the AUR isn't meant to support anything but arch but some people use it regardless) there's a package is the official repos which has the same name python-raspberry-gpio and is using Python 3.7, so it installs the package on /lib/python3.7/site-packages instead of using Python 3.8 and installing it over at /lib/python3.8/site-packages.

As a workaround you can install this package by running --aur flag on yay: yay --aur python-raspberry-gpio

However I'm now running into compiling issues, but again it's probably my system not being supported or me doing something wrong, but here's the error anyways:

collect2: error: ld returned 1 exit status
error: command 'gcc' failed with exit status 1
==> ERROR: A failure occurred in package().
    Aborting...
error making: python-raspberry-gpio

After a discussion on the Manjaro ARM forums the solution is to simply change python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 to env CFLAGS="-fcommon" python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 in the PKGBUILD

JP-Undercover commented on 2020-09-07 13:51

I'm running a Raspberry Pi 4 running Manjaro ARM (aarch64) and installing this package (using it as a dependency for the fanshim package) and trying to run the fanshim program with normal user or sudo returns:

Traceback (most recent call last):
  File "/usr/bin/fanshim", line 2, in <module>
    from fanshim import FanShim
  File "/usr/lib/python3.8/site-packages/fanshim/__init__.py", line 1, in <module>
    import RPi.GPIO as GPIO
ModuleNotFoundError: No module named 'RPi'

@DarioP said it worked fine for him after a patch given by @ava1ar 1 year ago, but I haven't been able to track it down.

My system:

  • Raspberry Pi 4
  • Manjaro ARM (aarch64)
  • Kernel 5.4

xpt commented on 2020-03-30 01:32

Thank you @mdevaev!!!

mdevaev commented on 2020-03-26 02:36

@xpt you will need to configure udev rules to change device permissions. See here: https://github.com/pikvm/packages/blob/master/packages/raspberrypi-io-access/udev.rules

xpt commented on 2020-03-25 18:53

How I can run it without superuser privileges?

mdevaev commented on 2019-10-22 20:17

I'm not sure if this patch will break the existing library behavior, even if I adapt it for the new version.