Package Details: python-pyxel 1.2.10-1

Git Clone URL: https://aur.archlinux.org/python-pyxel.git (read-only)
Package Base: python-pyxel
Description: Retro game development environment
Upstream URL: https://github.com/kitao/pyxel
Keywords: gamedev graphics oldschool pixels
Licenses: MIT
Submitter: xyproto
Maintainer: alexf91
Last Packager: alexf91
Votes: 1
Popularity: 0.000066
First Submitted: 2018-08-02 12:30
Last Updated: 2019-11-19 22:31

Latest Comments

alexf91 commented on 2019-08-14 18:05

@dlezo I know, I realized this a few days ago. It's only used for the packager, but pkg_resources.load_entry_point checks all dependencies when a console script is executed.

I'm now patching setup.py so that pyinstaller is only checked for pyxelpackager. pyinstaller is now an optional dependency.

I'll raise the issue upstream.

dlezo commented on 2019-08-14 16:46

I just realized that pyinstaller is also needed. Without it pyxeleditor crashes on launch.

dlezo commented on 2019-08-06 19:13

Great. Thank you for your work!

alexf91 commented on 2019-08-05 17:54

@dlezo I have added sdl2_image (not the multilib version) as a dependency. Building works in a new x86_64 Arch installation.

dlezo commented on 2019-08-05 16:26

I think python-pyxel 1.1.8-1 is missing this dependency: lib32-sdl2_image