Package Details: python-pystache 0.5.4-7

Git Clone URL: https://aur.archlinux.org/python-pystache.git (read-only)
Package Base: python-pystache
Description: The mustache template engine written in python
Upstream URL: http://github.com/defunkt/pystache
Licenses: MIT
Submitter: flokli
Maintainer: actionless (SirCmpwn)
Last Packager: actionless
Votes: 18
Popularity: 2.26
First Submitted: 2014-04-05 11:17
Last Updated: 2019-12-06 21:16

Latest Comments

1 2 Next › Last »

alfredo.ardito commented on 2019-12-06 21:41

great, ti worked. it was a lightning fix :)

actionless commented on 2019-12-06 21:14

@alfredo.ardito fixed

alfredo.ardito commented on 2019-12-06 21:05

Got this error updating:

File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 900, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 786, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pystache==0.5.4' distribution was not
found and is required by the application
==> ERROR: A failure occurred in check().
Aborting...
==> ERROR: Makepkg was unable to build python-pystache.
==> Restart building python-pystache ? [y/N]
==> ----------------------------------------
==> ==> ERROR: unable to update

Fabius commented on 2019-11-24 17:15

Temporary fix untill maintainer updates this package:

git clone <https://aur.archlinux.org/python-pystache.git>

cd python-pystache

Edit PKGBUILD file and replace line 27:

PYTHONPATH=../test_dir/usr/lib/python3.7/site-packages/ \

With this:

PYTHONPATH=../test_dir/usr/lib/python3.8/site-packages/ \

Then run:

makepkg -si

Magbed commented on 2019-11-15 01:22

Broken with latest python 3.8.

Traceback (most recent call last):
  File "../test_dir/usr/bin/pystache-test", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3251, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3234, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3263, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pystache==0.5.4' distribution was not found and is required by the application
==> ERROR: A failure occurred in check().
    Aborting...
:: failed to build python-pystache package(s)

cristi.bourceanu commented on 2019-07-24 01:07

I have the same issue in check() section of PKGBUILD

I've tried both python-pystache and python-pystache-git


Installing pystache-test script to ../test_dir/opt/anaconda/bin
/home/cristi/.cache/yay/python-pystache-git/PKGBUILD: line 31: ../test_dir/usr/bin/pystache-test: No such file or directory
==> ERROR: A failure occurred in check().
    Aborting...
Error making: python-pystache-git

Improvotter commented on 2019-04-19 16:29

Is it possible to change the installation to make this work with pyenv?

Current I'm getting the following error:

Installing pystache-test script to ../test_dir/home/user/.pyenv/versions/3.7.2/bin
/home/user/.cache/yay/python-pystache/PKGBUILD: line 27: ../test_dir/usr/bin/pystache-test: No such file or directory
==> ERROR: A failure occurred in check().
    Aborting...
Error making: python-pystache

The -git version of this package doesn't have this issue. It also doesn't mention having to jump through some hoops for the Python 2to3 conversion.

frealgagu commented on 2019-04-13 15:26

Should python be a dependency?

SirCmpwn commented on 2019-02-28 04:44

Cheers, fixed.

netlexer commented on 2019-02-28 04:43

Validity check fails:

==> Validating source files with sha256sums... python-pystache-0.5.4.tar.gz ... FAILED

==> ERROR: One or more files did not pass the validity check!

$ grep sha256sums PKGBUILD sha256sums=('f7bbc265fb957b4d6c7c042b336563179444ab313fb93a719759111eabd3b85a')

$ sha256sum python-pystache-0.5.4.tar.gz | cut -f1 -d' ' 163f5b8fb45f6be3a5074a53a47e79ef51ec015ee43f3ec34b16be279147c96f