Package Details: python-pygccxml 1.9.1-2

Git Clone URL: https://aur.archlinux.org/python-pygccxml.git (read-only, click to copy)
Package Base: python-pygccxml
Description: Simple framework to navigate C++ declarations, using Python classes.
Upstream URL: https://github.com/gccxml/pygccxml
Licenses: boost
Provides: pygccxml
Replaces: pygccxml
Submitter: FabioLolix
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 24
Popularity: 0.000020
First Submitted: 2020-03-03 17:54
Last Updated: 2020-03-03 18:19

Dependencies (3)

Required by (8)

  • complx (requires pygccxml)
  • ns3 (requires pygccxml)
  • ns3-hg (requires pygccxml)
  • ompl (requires pygccxml) (optional)
  • ompl-git (requires pygccxml) (optional)
  • omplapp (requires pygccxml) (optional)
  • py++ (requires pygccxml)
  • py++-svn (requires pygccxml)

Sources (1)

Latest Comments

FabioLolix commented on 2018-12-08 21:40

Hi,

Update to use CastXML https://pygccxml.readthedocs.io/en/master/install.html

License is Boost, a common one

Please use unique filename for sources https://wiki.archlinux.org/index.php/PKGBUILD#source

Likely this package should be called python-pygccxml since don't have any files outside of /usr/lib/python2.7/site-packages https://wiki.archlinux.org/index.php/Python_package_guidelines#Package_naming

bchretien commented on 2013-06-06 13:22

Here is an up-to-date version of the PKGBUILD:

https://github.com/bchretien/PKGBUILD/blob/master/pygccxml/PKGBUILD

mortbauer commented on 2013-05-06 15:02

Hey can you please update the package, first the dependency is gccxml-git and the url isn't working anymore as well. Thank you

wych commented on 2013-02-26 10:09

please update gccxml-cvs to gccxml-git

mschu commented on 2013-02-12 21:48

Hi,
Please update to use gccxml-git. The CVS version is obsolete.

Anonymous comment on 2011-03-21 08:08

Elements in a bash array are space separated, hence
depends=('gccxml-cvs','python2')
should be
depends=('gccxml-cvs' 'python2')

sftrytry commented on 2011-03-20 15:26

As arch moves to python3, It would be better to add depends of python2 and use python2 setup.py in PKGBUILD.