Package Details: python-pyelliptic 2.0.1-2

Git Clone URL: https://aur.archlinux.org/python-pyelliptic.git (read-only)
Package Base: python-pyelliptic
Description: Python OpenSSL wrapper for ECC (ECDSA, ECIES), AES, HMAC, Blowfish, ...
Upstream URL: https://github.com/radfish/pyelliptic
Licenses: GPL3
Submitter: robertfoster
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 6
Popularity: 0.000000
First Submitted: 2019-04-02 15:45
Last Updated: 2019-11-07 18:47

Latest Comments

onny commented on 2019-11-07 11:31

Package fails to build in chroot: /startdir/PKGBUILD: line 23: python2: command not found

redfish commented on 2019-03-31 19:48

@robertfoster: in addition to my previous comment about py2/py3 split package, since the upstream deprecated the package, let's switch to a known maintained fork of it, that is maintained by Bitmessage. I extracted the commits from Bitmessage repo and reapplied to pyelliptic upstream and called it pyelliptic v2.0: https://github.com/radfish/pyelliptic . Also see discussion about the Bitmessage fork of pyelliptic here: https://github.com/HelloZeroNet/ZeroNet/issues/917

PKGBUILD for v2 is in branch v2 here: https://github.com/radfish/python-pyelliptic

Since nothing depends on the package so far, there should be no issue. I will then have zeronet package depend on this pyelliptic v2.

redfish commented on 2019-03-30 01:24

@roberfoster: here's a patch to create both Py2 and Py3 packages: https://github.com/radfish/python-pyelliptic

Since the name of this package is python2, I think we have to create a new package python-pyelliptic that will build both versions and delete this package.