Package Details: python-pydstool 0.91.0-1

Git Clone URL: https://aur.archlinux.org/python-pydstool.git (read-only, click to copy)
Package Base: python-pydstool
Description: Simulation and analysis environment for dynamical systems
Upstream URL: http://pydstool.sf.net/
Licenses: BSD
Replaces: python2-pydstool
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 1
Popularity: 0.000000
First Submitted: 2020-05-24 18:51
Last Updated: 2021-09-07 08:09

Pinned Comments

mschu commented on 2020-06-24 14:20

python<3 support has been removed upstream: there will be no further updates, switch to python-pydstool for latest version

Latest Comments

carlosal1015 commented on 2021-09-06 23:33

Hi, I have the following error:

==> Making package: python-pydstool 0.91.0-1 (Mon 06 Sep 2021 06:32:18 PM -05)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found PyDSTool-0.91.0.tar.gz
==> Validating source files with sha256sums...
    PyDSTool-0.91.0.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting PyDSTool-0.91.0.tar.gz with bsdtar
==> Sources are ready.
==> Making package: python-pydstool 0.91.0-1 (Mon 06 Sep 2021 06:32:19 PM -05)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
Traceback (most recent call last):
  File "/tmp/makepkg/python-pydstool/src/pydstool-0.91.0/setup.py", line 23, in <module>
    from setuptools import setup, os, find_packages
ModuleNotFoundError: No module named 'setuptools'
==> ERROR: A failure occurred in build().
    Aborting...
checking dependencies...

mschu commented on 2020-06-24 14:20

python<3 support has been removed upstream: there will be no further updates, switch to python-pydstool for latest version