Package Details: python-pafy-git 0.5.4.r16.g7c31503-1

Git Clone URL: https://aur.archlinux.org/python-pafy-git.git (read-only)
Package Base: python-pafy-git
Description: Python API for YouTube - Download videos and retrieve metadata from YouTube.
Upstream URL: https://github.com/mps-youtube/pafy
Licenses: LGPL3
Conflicts: python-pafy
Provides: python-pafy
Submitter: demize
Maintainer: demize
Last Packager: demize
Votes: 11
Popularity: 0.000218
First Submitted: 2014-02-06 01:11
Last Updated: 2018-07-12 22:15

Dependencies (3)

Required by (2)

Sources (1)

Latest Comments

SolarAquarion commented on 2019-07-09 21:36

you need to python-setuptools or whatever it's termed

ids1024 commented on 2018-06-14 23:40

@FichteFoll For reference, the project moved to the mps-youtube organization a while ago. GitHub places a redirect when a repository is moved to an organization, but np1 deleted the repos (from the organization) after GitHub's acquisition. They've since been restored, but I guess that broke the redirect.

This doesn't change your point that the url should be changed here, but I thought I might as well clarify that the new url is "official" and that the organization was set up by the original author.

FichteFoll commented on 2018-06-14 22:38

The author pulled all their repositories from Github after Microsoft aquired it.

https://github.com/np1/pafy is a 404 and the only repo on that account is https://github.com/np1/Fuck-Microsoft.

A replacement is available on the mps-youtube org at https://github.com/mps-youtube/pafy, found via their IRC channel.

parkerlreed commented on 2017-03-06 01:45

EDIT: Odd I was using the youtube-dl from the main repo but even just trying to use youtube-dl itself I got

pkg_resources.DistributionNotFound: The 'youtube-dl==2017.3.2' distribution was not found and is required by the application

Manullay installed with pip and it seems to be working fine.

----

Is upstream broken?

:: Building python-pafy-git package(s)...
==> Making package: python-pafy-git 0.5.3.1.r1.g726c1a7-1 (Sun Mar 5 20:45:25 EST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Entering fakeroot environment...
==> Starting package()...
Traceback (most recent call last):
File "setup.py", line 13, in <module>
from pafy import __version__
File "/home/parker/.cache/pacaur/python-pafy-git/src/pafy/pafy/__init__.py", line 7, in <module>
from .pafy import new
File "/home/parker/.cache/pacaur/python-pafy-git/src/pafy/pafy/pafy.py", line 52, in <module>
"pafy: youtube-dl not found; you can use the internal backend by "
ImportError: pafy: youtube-dl not found; you can use the internal backend by setting the environmental variable PAFY_BACKEND to "internal". It is not enabled by default because it is not as well maintained as the youtube-dl backend.
==> ERROR: A failure occurred in package().
Aborting...
:: failed to build python-pafy-git package(s)