Package Details: python-open3d-git r2485.e5ba382f-1

Git Clone URL: https://aur.archlinux.org/open3d-git.git (read-only, click to copy)
Package Base: open3d-git
Description: A Modern Library for 3D Data Processing
Upstream URL: http://www.open3d.org
Licenses: MIT
Conflicts: python-open3d-git, python-py3d, python-py3d-git
Provides: python-py3d
Submitter: deltaecho
Maintainer: jgwak
Last Packager: jgwak
Votes: 3
Popularity: 1.12
First Submitted: 2018-05-01 14:28
Last Updated: 2020-02-12 16:06

Latest Comments

stevesp commented on 2020-02-13 09:15

@jgwak Thanks for fixing the dependency issue, it is working for me now.

stevesp commented on 2020-02-12 16:42

@jgwak A okay, thanks for the info. Was only building the master branch and that worked without a problem (only the fix_3rdparty_path.patch was necessary). So the git package is the way to go right now if you want to have the new features of 0.9.0.

I see, guess in that case it makes sense to leave them.

Your welcome, thanks for fixing it.

jgwak commented on 2020-02-12 16:00

@stevesp There is a upstream bug blocking latest version build: https://github.com/intel-isl/Open3D/issues/1414 Regarding the strange packaging, I am not the one who submitted this package. I recently adopted it to fix this abandoned package. I wonder the same but I decided to leave them for backward compatibility. I will fix typo and error in dependency. Thank you.

stevesp commented on 2020-02-12 10:57

Building the git version of open3d is not working since python-open3d-git is depending on open3d and open3d is an older version. I fixed this problem by adapting the "package_open3d-git" function to provide open3d and conflict with "open3d" instead of "open3d-git". Another possibility would be to make the python-open3d-git package dependent on open3d-git instead of open3d.

In addition, I was wondering why there is a python-py3d-git package function in the PKGBUILD which is basically the same as the python-open3d-git package function? In both of those functions, there is a typo: "privides" instead of "provides". Also, should both packages provide "python-open3d" and "python-py3d" and conflict with each other and the same package versions without git.

otaj commented on 2019-02-02 20:54

PKGBUILD is "out of date" - since version 0.3.0, it is required to cmake .., not cmake ../src plus it is necessary to init submodule 3rdparty, since otherwise the install fails.