Package Details: python-numba 0.49.1-1

Git Clone URL: https://aur.archlinux.org/python-numba.git (read-only, click to copy)
Package Base: python-numba
Description: NumPy aware dynamic Python compiler using LLVM
Upstream URL: http://numba.pydata.org/
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 35
Popularity: 1.84
First Submitted: 2014-05-10 20:33
Last Updated: 2020-05-11 20:54

Latest Comments

« First ‹ Previous 1 2 3

c3real-killer commented on 2016-02-13 16:03

Just downgraded llvm and llvm-libs to 3.6.2-4, and installed python-numba. Then when importing got:

OSError: /usr/lib/python3.5/site-packages/llvmlite/binding/libllvmlite.so: undefined symbol: _ZN4llvm3sys22getDefaultTargetTripleB5cxx11Ev

mschu commented on 2016-02-11 14:29

Have you tried with llvm=3.7.0? If it works, I can add a mask to hard-require it.

c3real-killer commented on 2016-02-11 14:20

It would be safe to downgrade LLVM to 3.7?

mschu commented on 2016-02-11 10:25

The issue here is not numba but python-llvmlite that does not compile because of a missing include/llvm/Targets/TargetLibraryInfo.h. Upgrading to 0.9.0.dev does not solve it.

The Arch package for llvm does provide a file with the same name in include/llvm/Analysis/TargetLibraryInfo.h, but they are not compatible (compile error because of missing function definitions).

This does not seem to be trivial to fix and I'm limited on time right now. Patches for python-llvmlite welcome.

c3real-killer commented on 2016-02-10 18:43

Cannot be installed with LLVM 3.7.1-1 (current). Any hope that this will be fixed soon?

mschu commented on 2016-01-18 09:48

Updated, thanks.

ayr0 commented on 2015-01-11 04:55

Could you make this installable along side the python2 version? Currently, only the python2 or the python3 version can be installed, but not both.

mschu commented on 2014-08-30 14:56

I'm in the process of updating a couple of packages, including this one.

It is not true that this is a duplicate, see the "python" commands for building/installing instead of the "python2". However, the dependencies should be set to python>3 packages as well - thanks for spotting this.

qs9rx commented on 2014-08-30 14:32

This seems to be an outdated duplicate of https://aur.archlinux.org/packages/python2-numba/ , not a python3 version as the name would suggest. Could you please update it to python3 or remove it?