Package Details: python-numba 0.49.1-1

Git Clone URL: https://aur.archlinux.org/python-numba.git (read-only, click to copy)
Package Base: python-numba
Description: NumPy aware dynamic Python compiler using LLVM
Upstream URL: http://numba.pydata.org/
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 35
Popularity: 1.92
First Submitted: 2014-05-10 20:33
Last Updated: 2020-05-11 20:54

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

zsrkmyn commented on 2017-12-23 17:52

python-numpy is needed as depends.

mschu commented on 2017-12-17 14:14

Updated & release bumped (checksum changed)

renato_garcia commented on 2017-07-25 17:37

I think that the md5sum on PKGBUILD is wrong. The correct one is
md5sums=('00b8fbe8c9c1d2dc83cdd5a529072a98')

axil commented on 2016-12-02 08:10

I've installed llvm-3.8.1-1 from arch archive (and the corresponding llvm-libs). After that this python-numba package installs and works fine.

Anonymous comment on 2016-03-27 12:31

MD5 sums check doesn't pass.

mschu commented on 2016-03-01 22:32

Thanks for the comment, I added the version requirement to the PKGBUILD.

lonaowna commented on 2016-03-01 20:59

python-numba is currently broken in combination with the latest python-llvmlite 0.9.0
This will be fixed any moment with Numba 0.24.[1]

[1] https://github.com/numba/numba/issues/1729

mschu commented on 2016-02-19 14:31

For LLVM 3.7 support, use python-llvmlite-git until 0.9.0 stable is released.

lonaowna commented on 2016-02-19 12:28

FYI:
Numba works with LLVM 3.7 + python-llvmlite-git + python-numba-git

mschu commented on 2016-02-14 20:41

You need to recompile python-llvmlite. Unfortunately, PKGBUILDs don't support that "recompile dependency" flag.