Package Details: python-nbgrader 0.6.1-2

Git Clone URL: https://aur.archlinux.org/python-nbgrader.git (read-only, click to copy)
Package Base: python-nbgrader
Description: A system for assigning and grading notebooks
Upstream URL: https://github.com/jupyter/nbgrader
Licenses: BSD
Submitter: flying-sheep
Maintainer: flying-sheep
Last Packager: flying-sheep
Votes: 0
Popularity: 0.000000
First Submitted: 2020-07-24 08:36
Last Updated: 2020-08-25 08:43

Latest Comments

leuko commented on 2021-05-12 07:04

What do you think about renaming the package to jupyter-nbgrader?

I saw that many jupyter related packages have this prefix.

Update:

On a second thought, I think python- prefix is ok. Then we stay in the namespace of pypi.

flying-sheep commented on 2020-12-08 22:33

Well, I didn’t think I’d ever say this, but Eli Schwartz is wrong (I thought he’s always right! XD) The Python packaging environment doesn’t have a concept of “meta packages”, so “jupyter” is just a regular “distribution” (that’s how installable packages with metadata are called in the Python world)

And as such it should have its dist-info/egg-info.

I’ll reply the same in the thread/bug report.

leuko commented on 2020-12-08 18:41

Dear @flying-sheep, I reported a bug [1], but other experienced users say that a dist-info is not needed for metapackages [2]. I am not experienced with Python packaging. Can you please comment on [2]?

[1] https://bugs.archlinux.org/task/68884 [2] https://bbs.archlinux.org/viewtopic.php?pid=1942362

flying-sheep commented on 2020-12-06 21:46

This package already depends on jupyter. Please report a bug for the package community/jupyter which seems to fail shipping a jupyter.dist-info directory

leuko commented on 2020-12-04 05:42

@tinux

You can also use pipman until this package is fixed.

pipman nbgrader
cd python-nbgrader
makepkg -i

leuko commented on 2020-11-30 20:44

I can confirm tinux:

$ nbgrader quickstart --help
...
pkg_resources.DistributionNotFound: The 'jupyter' distribution was not found and is required by nbgrader

tinux commented on 2020-10-30 13:24

I'm getting a whole bunch of errors ending with pkg_resources.DistributionNotFound: The 'jupyter' distribution was not found and is required by nbgrader when I run nbgrader quickstart --help.

Any advice?

flying-sheep commented on 2020-08-25 08:44

ah, whoops, right! it uses rapidfuzz only on master, stable still uses fuzzywuzzy

rubdos commented on 2020-08-11 13:02

pkg_resources.DistributionNotFound: The 'fuzzywuzzy' distribution was not found and is required by nbgrader

Mind adding python-fuzzywuzzy to deps?