Package Details: python-mahotas 1.4.5-2

Git Clone URL: https://aur.archlinux.org/python-mahotas.git (read-only)
Package Base: python-mahotas
Description: A fast computer vision algorithms (all implemented in C++) operating over numpy arrays
Upstream URL: http://luispedro.org/software/mahotas
Licenses: MIT
Submitter: davidmcinnis
Maintainer: davidmcinnis
Last Packager: davidmcinnis
Votes: 1
Popularity: 0.000000
First Submitted: 2015-10-13 21:58
Last Updated: 2019-01-07 09:13

Latest Comments

davidmcinnis commented on 2019-10-28 05:14

If I update to 1.4.7 I get a failing unittest:
FAIL: mahotas.tests.test_convolve.test_convolve1d

Traceback (most recent call last): File "/usr/lib/python3.7/site-packages/nose/case.py", line 197, in runTest self.test(*self.arg) File "/home/dave/projects/aur-python-mahotas/src/mahotas-1.4.7/mahotas/tests/test_convolve.py", line 241, in test_convolve1d assert np.all(fw == f1w) AssertionError


Not going to want to update the package till we get this test issue figured out.

anntzer commented on 2016-10-08 23:02

You can drop all makedepends too: matplotlib and numpydoc are only necessary for the docs, and gcc is in base-devel, which is always assumed to be installed when building from AUR anyways (see note at https://wiki.archlinux.org/index.php/PKGBUILD#makedepends).

davidmcinnis commented on 2016-10-08 04:53

Will do anntzer. Thanks for letting me know about the messed up docs issue.

-Dave

anntzer commented on 2016-10-07 22:18

Can you remove the docs-building and -installing from the PKGBUILD? The docs don't build correctly on Py3 due to the use of xrange in some examples, and the correctly built pages use a sphinx style that's different from the official docs.

Thanks.