Package Details: python-llvmlite 0.36.0-1

Git Clone URL: https://aur.archlinux.org/python-llvmlite.git (read-only, click to copy)
Package Base: python-llvmlite
Description: Lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 27
Popularity: 0.26
First Submitted: 2014-12-29 17:23
Last Updated: 2021-03-12 09:27

Latest Comments

1 2 3 4 5 6 ... Next › Last »

PandaFoss commented on 2021-03-08 00:37

Please change checksum to 745814006458b74039b056d1fa7ae93191a3a3a5daf0e5215891ca35e910ea64a8

a821 commented on 2020-11-18 07:02

That sounds like a bug in pacaur and pamac, or you mirror is outdated, or some config issue, etc...

I recently rebuilt python-llvmlite in a clean chroot, put it in my local repo, and upgraded with pacman with zero issues.

snarfies commented on 2020-11-17 13:25

pacaur gives the following output:

:: no results found for llvm10>=10.0.0 (dependency tree: python-llvmlite llvm10)

:: no results found for llvm10<10.1.0 (dependency tree: python-llvmlite llvm10)

:: no results found for llvm10-libs>=10.0.0 (dependency tree: python-llvmlite llvm10-libs)

:: no results found for llvm10-libs<10.1.0 (dependency tree: python-llvmlite llvm10-libs)

The current version of llvm10 is llvm10 10.0.1-1, but the dependency syntax doesn't seem to be picking that up.

pamac yields similar results.

jlaehne commented on 2020-11-13 10:04

I resorted to installing https://aur.archlinux.org/packages/python-llvmlite-bin instead to be independent of the dependencies. Thanks for the quick reply!

mschu commented on 2020-11-13 10:03

@jlaehne: No, because llvm>=11 is not supported by llvmlite: https://github.com/numba/llvmlite/issues/639

You will need to switch to llvm10{,-libs} (remove llvm with -Rdd), update python-llvmlite, and then switch back to llvm=11 but keep the llvm10-libs.

If someone has a better solution please suggest.

jlaehne commented on 2020-11-13 09:56

Is it possible to remove the < dependencies that restrict updates of llvm and llvm-libs? Getting

:: installing llvm-libs (11.0.0-1) breaks dependency 'llvm-libs<10.1.0' required by python-llvmlite

And it is not the first time that llvmlite is giving me troubles on updates.

daskol commented on 2020-06-03 19:23

It is possible to build 0.33.0rc1 with extra/llvm9.

diff --git a/PKGBUILD b/PKGBUILD
index 070c762..312e340 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,15 @@
 # Maintainer: Michael Schubert <mschu.dev at gmail>
 pkgname=python-llvmlite
-pkgver=0.32.1
+pkgver=0.33.0rc1
 pkgrel=1
 pkgdesc="Lightweight LLVM python binding for writing JIT compilers"
 url="https://github.com/numba/llvmlite"
 arch=('i686' 'x86_64')
 license=('BSD')
-#depends=('python' 'llvm-libs>=7.0.0' 'llvm-libs<9.1.0')
-#makedepends=('cython' 'llvm>=7.0.0' 'llvm<9.1.0')
-depends=('python' 'llvm8-libs')
-makedepends=('cython' 'llvm8')
+depends=('python' 'llvm9-libs')
+makedepends=('cython' 'llvm9')
 source=(llvmlite-$pkgver.tar.gz::"https://github.com/numba/llvmlite/archive/v$pkgver.tar.gz")
-sha256sums=('ab68a28dff64973ed93bec8c8ef5aa8d5449750df0a12cb84a4ea18ace8a3adb')
+sha256sums=('426677af96b3c70bb3ce1bb780822cf1d14876d24f351b895f524f0c7ebb66ec')

 build() {

andalenavals commented on 2020-05-04 06:15

sha256sums=('a2f36b90d2dffa5be204cab68506ac4da49216d43f350094e233a2a68022359e')

petronny commented on 2020-04-26 03:45

@JohnRobson See https://github.com/numba/llvmlite#compatibility and https://github.com/numba/llvmlite/issues/523

JohnRobson commented on 2020-04-05 17:37

Why depends of llvm8 and not llvm?