Package Details: python-llvmlite-bin 0.34.0-1

Git Clone URL: https://aur.archlinux.org/python-llvmlite-bin.git (read-only, click to copy)
Package Base: python-llvmlite-bin
Description: A lightweight LLVM python binding for writing JIT compilers
Upstream URL: http://llvmlite.pydata.org
Licenses: GPL
Conflicts: python-llvmlite
Provides: python-llvmlite=0.34.0
Submitter: yuri
Maintainer: yuri
Last Packager: yuri
Votes: 2
Popularity: 0.000001
First Submitted: 2016-09-04 09:31
Last Updated: 2020-08-28 21:05

Dependencies (1)

Required by (11)

Sources (1)

Latest Comments

bcb commented on 2020-12-02 12:29

I'm not sure if its fully supported on 3.9 yet actually. I couldn't confirm on the llvmlite repository, but this issue on the Numba repository suggests the bytecode changes in Python 3.9 make it unreliable (I can confirm some of my numba code doesn't yet work in 3.9!). They mention a point release of numba in mid-December to add 3.9 support, maybe llvmlite will be updated then too.

yuri commented on 2020-12-02 12:02

I don't see a py39 version on the anaconda website yet. I am waiting for it to update to llvmlite 0.35 and python 3.9 https://anaconda.org/numba/llvmlite/files

bcb commented on 2020-12-02 10:40

Needs updating to get a Python 3.9 build.

yuri commented on 2019-11-19 11:26

Thanks, I updated with that link and it seems to work

bcb commented on 2019-11-19 08:49

There is a Python 3.8 build at

https://anaconda.org/anaconda/llvmlite/0.30.0/download/linux-64/llvmlite-0.30.0-py38hd408876_0.tar.bz2

(note /anaconda rather than /numba in the second part of the URL).

I haven't run the full Numba test suite yet but some basic tests suggest it works.

yuri commented on 2019-11-15 11:02

python3.8 hit the repos, but the official llvmlite binaries only support 3.7 for version 0.30.0.

Should I bump to version 0.31.0dev0 (which has python3.8 binaries) or wait for the proper 0.31.0 version?

Usually I only update on stable releases, but I could make an exception considering the circumstances.

I know some people use this package for numba, so I am open to suggestions

yuri commented on 2019-10-22 22:01

@bcb I just did that (and updated to 0.30.0)

bcb commented on 2019-10-22 07:45

Can you please add the version number to provides so that python-numba can build? See https://wiki.archlinux.org/index.php/PKGBUILD#provides

Setting provides=("python-llvmlite=$pkgver") worked for me.