Package Details: python-leapmotion 2.3.1-3

Git Clone URL: https://aur.archlinux.org/python-leapmotion.git (read-only, click to copy)
Package Base: python-leapmotion
Description: The Leapmotion python interface, compiled for python 3
Upstream URL: https://developer.leapmotion.com/downloads
Licenses: unknown
Submitter: s-ol
Maintainer: s-ol
Last Packager: s-ol
Votes: 1
Popularity: 0.000794
First Submitted: 2019-01-26 18:59
Last Updated: 2019-12-14 18:35

Dependencies (5)

Required by (0)

Sources (2)

Latest Comments

frostwork commented on 2020-07-22 16:38

this package is as dead as the leap motion sdk linux sdk, right?

Terence commented on 2019-12-10 22:50

Just a little reminder that you have to change swig command inside the PKGBUILD to swig-3 and bump pkgrel.

Terence commented on 2019-12-08 14:27

Hehe all good :)

s-ol commented on 2019-12-08 12:54

@Terence ouf, you got me! I knew I should've done a testbuild, but I didnt have leap-motion-sdk installed anymore and since it's AUR makepkg -s didn't find it, so I got a bit lazy ;)

Terence commented on 2019-12-08 12:46

@s-ol Np, that was fast! You just forgot to replace the swig command inside the PKGBUILD by swig-3

s-ol commented on 2019-12-08 12:38

Thanks for the hint @Terence, I changed out the dependency as suggested.

Terence commented on 2019-12-08 12:30

It looks like it's not compatible with swig 4.0:

    import Leap
  File "/usr/lib/python3.8/site-packages/Leap.py", line 783, in <module>
    class Image(Interface):
  File "/usr/lib/python3.8/site-packages/Leap.py", line 834, in Image
    __swig_getmethods__["data"] = data
NameError: name '__swig_getmethods__' is not defined

The solution is to install swig-3 and replace it in the PKGBUILD.