Package Details: python-hyperspy 1.6.1-1

Git Clone URL: https://aur.archlinux.org/python-hyperspy.git (read-only, click to copy)
Package Base: python-hyperspy
Description: Hyperspectral data analysis
Upstream URL: http://hyperspy.org
Keywords: electron-microscopy scientific-data-analysis spectral-imaging
Licenses: GPL3
Conflicts: hyperspy
Provides: hyperspy
Replaces: hyperspy
Submitter: jlaehne
Maintainer: jlaehne (jat255)
Last Packager: jlaehne
Votes: 3
Popularity: 0.023889
First Submitted: 2020-09-01 08:10
Last Updated: 2020-12-02 12:29

Latest Comments

jat255 commented on 2020-11-13 18:06

I updated the git version of python-hyperspy to the binary package as well

jat255 commented on 2020-11-13 17:56

I agree, I think requiring the bin package is probably wise (I just faced this issue myself with an upgrade). Since it provides the "non-bin" package, anyone who doesn't like this can just install the regular python-llvmlite package manually to get around using a binary package.

jlaehne commented on 2020-11-13 10:09

I propose to install https://aur.archlinux.org/packages/python-llvmlite-bin instead of python-llvmlite (dependency of python-sparse through python-numba) as otherwise you might regularly face compatibility issues on updates of llvm-libs.

jlaehne commented on 2020-08-31 18:23

You're right, I have been pondering about that as well. I will clone to the new name in the next days and then we have to launch a merge request later. Same holds for the three related packages.

jat255 commented on 2020-08-31 17:16

@jlaehne, to conform with the python packaging guidelines, we should rename this package to "python-hyperspy", I think (https://wiki.archlinux.org/index.php/Python_package_guidelines)

jlaehne commented on 2019-11-18 15:23

I had to manually install python-fsspec, python-dask, python-distributed (in this order) using makpekg -sid, as there is a circular dependency between python-dask and python-distributed.

jlaehne commented on 2019-11-14 13:47

Note that python-sparse requires python-numba, which in turn requires python-llvmlite, where currently the PKGBUILD needs to be patched for a working install due to outdated llsm-dependencies. See https://aur.archlinux.org/packages/python-llvmlite/