Package Details: python-googletrans 3.1.0a0-1

Git Clone URL: https://aur.archlinux.org/python-googletrans.git (read-only, click to copy)
Package Base: python-googletrans
Description: Free Google Translate API for Python.
Upstream URL: https://github.com/ssut/py-googletrans
Licenses: MIT
Submitter: timschumi
Maintainer: timschumi
Last Packager: timschumi
Votes: 7
Popularity: 0.29
First Submitted: 2019-10-03 12:02
Last Updated: 2020-12-05 15:24

Latest Comments

1 2 Next › Last »

yochananmarqos commented on 2020-12-31 17:47

@timschumi: Please make the following changes.

depends=('python-httpx' 'python-h2')
makedepends=('python-setuptools')
optdepends=('python-hyper: faster http networking')

See here about using hyper.

fushinari commented on 2020-12-31 14:26

@yochananmarqos: yes, but seems there are issues with py-googletrans in specific (because http2=True is used in it). See: https://aur.archlinux.org/packages/dialect/#comment-781678 .

yochananmarqos commented on 2020-12-19 15:41

@fushinari: python-h2 is an optional dependency of python-httpcore which is a dependency of python-httpx.

fushinari commented on 2020-12-19 08:07

Please add python-h2 as a dependency because it seems py-googletrans is now forcing HTTP/2 support.

vivaeltopo commented on 2020-12-05 15:42

ty, I guess a probably working package is better than a not working package.

timschumi commented on 2020-12-05 15:22

I held off on updating since it was marked as a pre-release version. I'll update the package.

vivaeltopo commented on 2020-12-05 15:19

3.0.0 doesnt work anymore. Changing the pkgver to 3.1.0a0 allows to use a temporary fix

timschumi commented on 2020-12-02 12:34

Is that common procedure for Python packages? I have never seen an AUR python package bump its pkgrel whenever a new Python version is released.

Also, I don't see why you couldn't just rebuild the package.

fushinari commented on 2020-12-02 12:10

Python 3.9 is out for Arch. Pls up the pkgrel.

timschumi commented on 2020-10-06 10:58

Ah you were talking about building the package. I probably won't change the version declaration though because you'll have to downgrade the package manually anyways, no matter if its enforced when building or when enforced in the PKGBUILD.

If the package works fine with newer httpx versions, this is an upstream issue and you should ask them to make it a >=0.13.3.