Package Details: python-fontawesome 5.10.1.post1-1

Git Clone URL: https://aur.archlinux.org/python-fontawesome.git (read-only, click to copy)
Package Base: python-fontawesome
Description: The Font Awesome icon set for python
Upstream URL: https://github.com/justbuchanan/fontawesome-python
Licenses: Apache
Submitter: ganda
Maintainer: jgwak
Last Packager: jgwak
Votes: 2
Popularity: 0.000006
First Submitted: 2018-06-02 11:09
Last Updated: 2019-11-18 19:53

Latest Comments

jgwak commented on 2019-11-15 07:57

@TheEdgeOfRage If this package doesn't work with python 3.8, it is most likely because you need to rebuild your AUR package for python 3.8. You may find this thread useful https://www.reddit.com/r/archlinux/comments/dwalug/python_380_is_now_on_the_stable_repositories/f7hqajo/

berocs commented on 2018-10-30 18:10

The PKGBUILD should be updated like this:

# Maintainer: Daniel Nunes <daniel.henri.nunes_AT_gmail_DOT_COM>

pkgname=python-fontawesome
pkgver=5.3.1.post1
pkgrel=1
pkgdesc="The Font Awesome icon set for python"
url="https://github.com/justbuchanan/fontawesome-python"
depends=('python' )
makedepends=('python3' 'python-setuptools' 'python-pypandoc' 'python-yaml')
license=('Apache')
arch=('any')
source=('https://files.pythonhosted.org/packages/bb/e3/898b134ddae6efd617035e5be41a483442372fc3b62c5befd0f2e6764eed/fontawesome-5.3.1.post1.tar.gz')
sha256sums=('0ea1a65f0b94ad25bf8eee12cc0272357a6e00a6ea1fc1ad202aa6e962915ef2')

build() {
    cd $srcdir/fontawesome-5.3.1.post1
    ./fontawesome/generate.py > ./fontawesome/icons.py
    python setup.py build
}

package() {
    cd $srcdir/fontawesome-5.3.1.post1
    python setup.py install --root="$pkgdir" --optimize=1
}

berocs commented on 2018-10-30 17:53

It's missing a

./fontawesome/generate.py > ./fontawesome/icons.py

, as shown in the README:https://github.com/justbuchanan/fontawesome-python#build-