Package Details: python-efl 1.24.0-1

Git Clone URL: https://aur.archlinux.org/python-efl.git (read-only, click to copy)
Package Base: python-efl
Description: Python bindings for the Enlightenment Foundation Libraries
Upstream URL: http://www.enlightenment.org
Licenses: GPL3, LGPL3
Submitter: Scimmia
Maintainer: llde (philb38)
Last Packager: philb38
Votes: 56
Popularity: 0.006263
First Submitted: 2013-12-08 20:40
Last Updated: 2020-07-13 16:29

Pinned Comments

llde commented on 2020-01-06 16:34

I'm currently unable to build this, every time I try the computer slow to a crawl, and fail with an error.

IF any of you can build this succesfully and test it works as intended, please tell me. I will appoint a comantainer. Thanks for understainding.

Latest Comments

1 2 3 4 5 Next › Last »

llde commented on 2020-02-28 17:00

@philb38 Being newer doesn't matter. FX are of a problematic architecture (and evolution with the same problems), that was slower then frequency can make you think. Also it is prone to overheating ans so performance degradation for thermal throttling. Plus many motherboards for that architectures, expecially for first generations, had similar overheating issues on the VRM, and so other performance degradation.

The fact that with a laptop booting into the system and starting firefox made temperatures of 80-90C is indicative.

philb38 commented on 2020-02-28 09:42

I use an AMD PhenomII X4, so really older than yours... ;)

llde commented on 2020-02-15 11:04

I have 4GB RAM + 4GB swap. I don't even belive it's a memory problem. It's just the computer that hang for a long time then fail. Memory usage wasn't that high.

But I the CPU is an AMD A8 APU, of FX processor family, that may be the reason.

philb38 commented on 2020-02-12 13:06

@llde you probably miss some memory/swap space to compile. I was not able to compile with 1GB RAM + 4GB swap, but it went well with 2GB RAM + 8GB swap...

llde commented on 2020-02-11 12:56

@philb38 I added you as comantainer.

It seems that somehow my pc encounter some problems.

philb38 commented on 2020-02-05 09:56

I've been able to compile/install with python-efl-1.23.0 (took the PKGBUILD and replaced the source/pkgver/depends, and the sha256sums with the content of the shasum on the source URL). Took some time but compiled right, and seems to work... PKGBUILD:

# Maintainer: Doug Newgard <scimmia at archlinux dot info>
# Mantainer: Lorenzo Ferrillo <lorenzofersteam at live dot it>
_python=python
_pkgname=python-efl
pkgname=$_python-efl
pkgver=1.23.0
pkgrel=1
pkgdesc="${_python^} bindings for the Enlightenment Foundation Libraries"
arch=('i686' 'x86_64')
url="<http://www.enlightenment.org>"
license=('LGPL3' 'GPL3')
depends=('efl>=1.23.0' "$_python-dbus")
source=("<http://download.enlightenment.org/rel/bindings/python/>$_pkgname-$pkgver.tar.xz")
sha256sums=('2bdef4153e3df2ed3edef9f1ebb4554054405425247a9fabb3c784b48232d69b')
#sha256sums=('SKIP')
build() {
  cd $_pkgname-$pkgver

  $_python setup.py build
}

package() {
  cd $_pkgname-$pkgver

  $_python setup.py install --root="$pkgdir" --optimize=1

  install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" AUTHORS README ChangeLog
}

llde commented on 2020-01-06 16:34

I'm currently unable to build this, every time I try the computer slow to a crawl, and fail with an error.

IF any of you can build this succesfully and test it works as intended, please tell me. I will appoint a comantainer. Thanks for understainding.

davemds commented on 2019-12-13 21:06

yes it will fail if run against efl 1.23.1, this pkg should be updated to the latest python-efl version 1.23.0

philb38 commented on 2019-12-13 15:57

As efl have been updated to 1.23.1, shouldn't we have python-efl updated too? I don't get any error at compile time, but when trying to import efl, it looks like it fails...

adsun commented on 2019-10-02 13:24

@lightdot I used extra-x86_64-build from devtools to build this in a clean chroot. It builds fine.