Package Details: python-dill 0.3.2-2

Git Clone URL: https://aur.archlinux.org/python-dill.git (read-only, click to copy)
Package Base: python-dill
Description: Serialize all of python (almost)
Upstream URL: http://pypi.python.org/pypi/dill/
Licenses: BSD
Submitter: anntzer
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 16
Popularity: 0.42
First Submitted: 2014-12-08 21:44
Last Updated: 2020-06-20 12:11

Latest Comments

« First ‹ Previous 1 2

petronny commented on 2017-06-20 05:53

Hi, you should add python-setuptools and python2-setuptools as makedepends.

fordprefect commented on 2017-03-14 21:07

@greyltc: could you please elaborate what you mean? as far as i can see each version depends on the respective python release. please check and explain the problem you see in more detail. thank you.

greyltc commented on 2017-03-14 17:39

Can you please make the python2-dill package not depend on python3?

fordprefect commented on 2016-11-19 21:55

convinced, thus implemented.

xantares commented on 2016-11-19 08:50

hi,
they should expect this, for example look at the files in /usr/bin from python2-sphinx:
https://www.archlinux.org/packages/community/any/python2-sphinx/
xan.

fordprefect commented on 2016-11-17 21:57

hi xantares,
thanks for your suggestion. i am not sure this is a good solution since python2-users might not expect to find their unpickle-command at another name, but i still like your solution, so adding an installation note may be enough.
maybe some regular python2-users speak up about their preferences.
if this does not happen in a reasonable time, i will implement this.

xantares commented on 2016-11-16 17:58

Hello,
Usually this kind of conflict is addressed by renaming the files.
Since python3 should be the default, I would move the python2-dill files:
mv "$pkgdir/usr/bin/get_objgraph.py" "$pkgdir/usr/bin/get_objgraph2.py"
mv "$pkgdir/usr/bin/unpickle.py" "$pkgdir/usr/bin/unpickle2.py"
How about that ?
xan.