Package Details: python-dill 0.3.1.1-1

Git Clone URL: https://aur.archlinux.org/python-dill.git (read-only, click to copy)
Package Base: python-dill
Description: Serialize all of python (almost)
Upstream URL: http://pypi.python.org/pypi/dill/
Licenses: BSD
Submitter: anntzer
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 14
Popularity: 0.74
First Submitted: 2014-12-08 21:44
Last Updated: 2019-09-28 19:44

Latest Comments

1 2 Next › Last »

fordprefect commented on 2020-01-09 14:41

@iyanmv: Please refrain from flagging packages out-of-date when requesting changes, it is intended to notify the maintainer of a new version. Regarding your request: In the forseeable future python2 will be dropped. However, there still is an update announced for April, meaning it is not obsolete yet. I will move the makedepends to the respective package, but you can always edit the PKGBUILD before building - so nothing is being forced on you here!

EDIT: Makepkg does not allow makedepends in package function, so the only way to comply to your request would be unsplitting the package. I prefer keeping the split package until the final drop of Python2, which I expect to happen some time this year.

iyanmv commented on 2020-01-09 14:30

I would like to be able to install python-dill without having to install python2 (because of makedpends). Moreover, support for python2 ended last 1st January, so I suggest you consider removing python2-dill package.

fordprefect commented on 2018-07-04 09:31

@jeancf: thanks, fixed.

jeancf commented on 2018-07-03 19:06

Error when building python-dill 0.2.8.2-1: mv: cannot stat '/tmp/yaourt-tmp-jeancf/aur-python-dill/pkg/python2-dill/usr/bin/get_objgraph.py': No such file or directory ==> ERROR: A failure occurred in package_python2-dill().

fordprefect commented on 2017-07-03 07:24

@petronny: thankyou, I will fix this.

petronny commented on 2017-07-03 06:06

Hi, makedepends shouldn't be in the package_*() functions.
Please add makedepends=('python-setuptools' 'python2-setuptools') before the package_*() funtions. So they can be detected before we go into the package_*() funtions.

fordprefect commented on 2017-06-25 16:28

@petronny: fixed, thanks for the hint.

petronny commented on 2017-06-20 05:53

Hi, you should add python-setuptools and python2-setuptools as makedepends.

fordprefect commented on 2017-03-14 21:07

@greyltc: could you please elaborate what you mean? as far as i can see each version depends on the respective python release. please check and explain the problem you see in more detail. thank you.

greyltc commented on 2017-03-14 17:39

Can you please make the python2-dill package not depend on python3?