Package Details: python-defcon 0.10.0-1

Git Clone URL: https://aur.archlinux.org/python-defcon.git (read-only, click to copy)
Package Base: python-defcon
Description: A set of UFO based objects for use in font editing applications
Upstream URL: https://github.com/robotools/defcon
Licenses: MIT
Submitter: wiill
Maintainer: thrasibule (alerque)
Last Packager: alerque
Votes: 3
Popularity: 0.000093
First Submitted: 2017-01-05 01:27
Last Updated: 2021-12-28 18:09

Pinned Comments

alerque commented on 2021-08-03 20:16

PSA: Like most of the PKGBUILDs that I (co-)maintain, I host prebuilt packages for this in my user repository and all its dependencies for those who wish to install it using pacman without messing around with building from the AUR. Issues or contributions are welcome either in comments below or via this GitHub repository.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

hwaiting commented on 2020-05-17 18:30

Even with python-ufolib2 it fails the tests on my system:

"Lib/defcon/test/objects/test_validation.py:58: AssertionError"

With python-ufolib as well it does pass the tests.

raxod502 commented on 2020-04-23 19:50

This needs a dependency on python-ufolib2, else the tests fail.

thrasibule commented on 2020-03-04 16:02

@caleb Can you tell me what's the issue that needs to be fixed? Last commit I've did was to bump the pkgrel. And package builds fine for me here.

alerque commented on 2020-03-04 06:56

@thrasibule This is still not fixed correctly. I commented on this last August, so did you, and you adopted ostensibly to fix the problem but the syntax you used is invalid. I commented on this in December and even though you added a commit since then you still didn't fix the original issue. Please either fix the dependency & syntax, orphan the package, or add me as a co-maintainer so this can be fixed properly. Thanks.

alerque commented on 2019-12-27 05:51

The last commit here fixes the previously bogus fixed dependency version (==), but it did not bump the package release so people like myself that installed in in the interim are unable to update without special arguments to force a rebuild. Please bump the package release number to reflect the change in dependencies so systems can update normally.

thrasibule commented on 2019-08-23 15:56

Actually it does depend on unicodedata2-12. If you don't have it installed, it downloads it.

thrasibule commented on 2019-08-23 15:54

I thought it depended on 12. I made a mistake, that happens... This package is not out of date, please don't flag it as such.

greyltc commented on 2019-08-23 14:56

And why do you specify ==12.0.0 anyway? No pytests here fail with unicodedata2 v11.

greyltc commented on 2019-08-23 14:51

probably don't use python-unicodedata2==12.0.0 if it does not exist

thrasibule commented on 2019-08-23 14:20

The dependency is there already. I've asked to bump the version in the AUR, and made an orphan request, but no replies yet.