Package Details: python-cartopy 0.17.0-3

Git Clone URL: https://aur.archlinux.org/python-cartopy.git (read-only)
Package Base: python-cartopy
Description: A cartographic python library with matplotlib support for visualisation
Upstream URL: https://scitools.org.uk/cartopy/docs/latest/
Licenses: LGPL3
Submitter: gauteh
Maintainer: gauteh (richli)
Last Packager: richli
Votes: 5
Popularity: 0.043216
First Submitted: 2015-11-16 16:00
Last Updated: 2019-08-27 23:54

Latest Comments

richli commented on 2019-08-27 23:54

@bcb: Thank you! I've included your hack into the PKGBUILD and disabled the tests for now.

bcb commented on 2019-08-05 12:02

Since PROJ (wrapped by python-pyproj) v6 the API cartopy uses has been deprecated. To use it requires a macro defined at build time. There is a pull request open to do so at https://github.com/SciTools/cartopy/pull/1289

In the meantime, this package fails to build. I added a quick hack in the prepare() function to add this define so it builds:

prepare() {
    cd "$srcdir/cartopy-${pkgver}"
    sed -i '/# Main setup/iextra_extension_args["define_macros"] = [("ACCEPT_USE_OF_DEPRECATED_PROJ_API_H", None)]\n' setup.py
}

Some of the tests fail (based on comments in the pull request linked above, I believe this is due to updates in PROJ which need to be reflected in the tests). Build with makepkg --nocheck to skip running the tests.

richli commented on 2018-12-06 23:16

@Stunts: I tried things out in a fresh container. It looks like by default, matplotlib, pillow, and scipy are all additionally required for the test suite. Since those are also probably required for "normal" usage of this package, I'll go ahead and promote them from optional to required dependencies. Thanks for the heads-up!

Stunts commented on 2018-12-06 23:01

@richli: It's required as in "the package fails to build unless it is installed". =-) It is also mentioned in ows.txt in the link you provided.

richli commented on 2018-12-06 18:46

@Stunts: How "required" is it? From what I can tell it's only optional.

https://github.com/SciTools/cartopy/tree/v0.17.0/requirements

Stunts commented on 2018-12-06 15:14

python-pillow is also a required dependency for this package.

Nestor_013 commented on 2018-04-22 14:39

A pseudo-diff for version 0.16.0

-pkgver=0.15.0 +pkgver=0.16.0

-md5sums=('98da94b1b1f844b31e679bdfdd6e0d96') +md5sums=('f9e2e528d7758da7c64f824548a53f32')

Full diff@ https://pastebin.com/jySKr0rX