Package Details: python-bokeh 1.3.4-3

Git Clone URL: https://aur.archlinux.org/python-bokeh.git (read-only)
Package Base: python-bokeh
Description: Interactive Web Plotting for Python
Upstream URL: http://bokeh.pydata.org/
Licenses: BSD
Submitter: xantares
Maintainer: gondsman
Last Packager: gondsman
Votes: 23
Popularity: 0.277537
First Submitted: 2015-04-16 12:51
Last Updated: 2019-09-06 08:23

Dependencies (15)

Required by (4)

Sources (1)

Latest Comments

1 2 Next › Last »

petronny commented on 2019-09-10 05:25

You need add makedepends=('python-setuptools' 'python2-setuptools') before the package_*() functions, or else they won't build in a clean chroot.

gondsman commented on 2019-08-30 14:00

Package updated, let me know if you have any more issues. :)

gondsman commented on 2019-08-28 09:23

Sorry for the delay, I'm out of town for work this week (also, why does gmail keep putting these notifications in the spam folder?). I'll update the package as soon as I can next week.

petronny commented on 2019-08-28 04:52

Please fix the dependencies.

ChrisTX commented on 2019-08-21 13:12

The package won't compile anymore due to Pandas 0.25 dropping support for Python 2 and currently no alternative being available (python2-pandas-git is broken as well due to trunk not supporting Py2 anymore).

According to the Bokeh documentation (and their setup.py), Pandas, NodeJS, psutil and a few other packages are only optional dependencies, so I assume that by correcting the optdepends array should sort this out. Doing so would also correct the currently missing optional Node (and more) dependencies.

gondsman commented on 2018-08-07 07:54

Maybe it just needs to be rebuilt against new versions of the dependencies. I haven't run into this issue, but it might be because I'm currently running Manjaro, so I'm a bit behind on updates. I'll increase the release number to "invite" people to rebuild it.

rmelo commented on 2018-08-06 23:17

After updating some python packages during regular update I get eh following error:

"pkg_resources.DistributionNotFound: The 'bokeh==0.13.0' distribution was not found and is required by the application"

Edit: Fresh installing the package solved the issue. Leaving the comment in case someone else runs into the problem.

gondsman commented on 2018-06-04 08:44

bokeh 0.12.16 was released, the PKGBUILD works fine by just changing version and checksum. I could adopt the package if people want, even though I'm not a python guru by any stretch.

phuijse commented on 2017-08-25 15:19

bkcharts>0.2 is needed to run "bokeh serve"

https://pypi.python.org/pypi/bkcharts

mSSM commented on 2016-09-15 11:25

Updated PKGBUILD. Also replaced the sha1sum by a md5sum. It's already provided on pypi, so why not use it?

http://ix.io/1n7v