Package Details: python-astropy-healpix 0.6-1

Git Clone URL: https://aur.archlinux.org/python-astropy-healpix.git (read-only, click to copy)
Package Base: python-astropy-healpix
Description: BSD-licensed HEALPix for Astropy
Upstream URL: http://astropy-healpix.readthedocs.io/
Keywords: astronomy astropy science
Licenses: BSD
Submitter: Universebenzene
Maintainer: Universebenzene
Last Packager: Universebenzene
Votes: 1
Popularity: 0.000000
First Submitted: 2018-02-02 07:45
Last Updated: 2021-08-18 00:50

Latest Comments

Universebenzene commented on 2021-08-18 00:50

@hhso It might be a strange problem with yay - the environment variable defined in prepare() can't be used in other functions. I did't get any problem while building with devtools.

hhso commented on 2021-08-17 20:44

Hi, I'm getting the following error when trying to install this package and I'm not sure how to fix it

==> Building Docs sphinx-build -b html -d _build/doctrees . _build/html Running Sphinx v4.1.2

Configuration error: There is a programmable error in your configuration file:

Traceback (most recent call last): File "/usr/lib/python3.9/site-packages/sphinx/config.py", line 327, in eval_config_file exec(code, namespace) File "/home/hector/.cache/yay/python-astropy-healpix/src/astropy_healpix-0.6/docs/conf.py", line 79, in <module> import_module(setup_cfg['name']) File "/usr/lib/python3.9/importlib/init.py", line 127, in import_module return _bootstrap._gcd_import(name[level:], package, level) File "<frozen importlib._bootstrap>", line 1030, in _gcd_import File "<frozen importlib._bootstrap>", line 1007, in _find_and_load File "<frozen importlib._bootstrap>", line 984, in _find_and_load_unlocked ModuleNotFoundError: No module named 'astropy_healpix'

make: *** [Makefile:44: html] Error 2 ==> ERROR: A failure occurred in build(). Aborting... error making: python-astropy-healpix

Universebenzene commented on 2019-02-25 02:54

Hi @mboquien, I finally figure out that the error occurs when the python2-pytest-cov is installed. So I add a conditional in check() function. You can try it again :)

Universebenzene commented on 2019-02-24 16:42

@mboquien That's strange. I rebuild the package just now and I didn't meet this error while testing... Anyway you can just use the --nocheck option for makepkg to skip checking. Or feel free to comment or delete the check() function before building :)

mboquien commented on 2019-02-24 16:29

Hi. It gets further but now it fails with the following message:

pluggy.manager.PluginValidationError: Plugin 'pytest_cov' could not be loaded: (pytest 3.2.5 (/usr/lib/python2.7/site-packages), Requirement.parse('pytest>=3.6'))!

I think the error is the python2-pytest32 requirement. That being said, is it useful to run the tests for user's packages? I saw that more as a developer's tool who do not use packages. Thanks!

Universebenzene commented on 2019-02-23 11:53

Hi @mboquien, I made a patch to fix this DeprecationWarning, so you can try again. Thanks for feedback!

mboquien commented on 2019-02-23 10:05

Hello. This package does not appear to build because of deprecation warnings taken as errors:

E DeprecationWarning: np.asscalar(a) is deprecated since NumPy v1.16, use a.item() instead /usr/lib/python3.7/site-packages/numpy/lib/type_check.py:546: DeprecationWarning

This in turn prevents the installation of python-reproject, which in turns prevents the update of python-aplpy as it now depends on the former.

Thanks!